apache2 erreichbar, aber Unterverzeichnis nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

apache2 erreichbar, aber Unterverzeichnis nicht

Postby Simon2018 » 26. January 2018 23:21

Ich habe owncloud nach folgender Anleitung installiert:
https://www.avoiderrors.net/owncloud-10-raspberry-pi-3-raspbian-stretch/

Nun kann ich über raspberry.local/owncloud meine Installation von owncloud erreichen.

Ich habe anschließend die Domain XXX.de registriert (die domain habe ich mit XXx zensiert) und eine frame-Weiterleitung eingerichtet. Wenn ich jetzt XXX.de eingebe, sehe ich die Standard-Seite des apache2. Wenn ich aber XXX.de/owncloud eingebe, kommt ein 404 error. Dabei läuft es im lokalen Netzwerk mit raspberry.local/owncloud einwandfrei.

Was muss ich beim apache einstellen, damit das korrekt funktioniert?
Simon2018
 
Posts: 4
Joined: 26. January 2018 22:48
XAMPP version: 2.4
Operating System: Windows / raspbian

Re: apache2 erreichbar, aber Unterverzeichnis nicht

Postby Simon2018 » 27. January 2018 09:24

Ich sollte noch folgendes ergänzen:

I have to use a portmapper to access my raspberrypi (in a DS Lite network)

To access owncloud, I enter
http://portmapper.myonlineportal.net:XXXXX/owncloud
(XXXXX is censored)

I registered a domain XXX.de. There I setup a frame redirect to http://portmapper.myonlineportal.net:XXXXX
When I enter XXX.de, I can acess my apache2 installation, but when I type XXX.de/owncloud, I get an error.

Can you help me here? What do I have to do?
Simon2018
 
Posts: 4
Joined: 26. January 2018 22:48
XAMPP version: 2.4
Operating System: Windows / raspbian

Re: apache2 erreichbar, aber Unterverzeichnis nicht

Postby Nobbie » 27. January 2018 11:10

In der Anleitung finde ich nichts, wie Du raspberry.local konfiguriert hast, das ist leider genau die Stelle, wo der Fehler wahrscheinlich liegt. Wenn Du es so gemacht hättest, wie Du behauptest es gemacht zu haben (wie in der Anleitung ausgeführt), dann würde es wahrscheinlich funktionieren. Ich vermute, Du hast irgendwo einen VirtualHost definiert (den es in der verlinkten Anleitung aber nicht gibt). In der Anleitung gibt es aussschließlich 192.168.1.140/0wncloud. Leider wissen wir hier nicht, auf welche IP raspberry.local verweist. Mit fehlt auch die Angabe, was Du angegeben hast als Ziel im frame. Das beschreibst Du auch nur "prosa" (habe ich eingerichtet), aber mit was?

Wir brauchen eine vollständige und richtige Beschreibung dessen, was Du gemacht hast.

P.S.: Insgesamt gefällt mir die Lösung auch nicht. Statt einer Domain mit Frameweiterleitung, hätte ich bei einem Anbieter dynamischer DNS EInträge eine Domain gebucht, ich selbst habe beispielsweise eine Domain bei www.selfhost.de eingerichtet, die jetzt auf meinen NAS verweist. Das ist ein echter DNS Eintrag und kein Frame (ich finde FRAME hässlich). Du musst nur sicherstellen, dass Dein Router den Dienst unterstützt und die dynamischen IPs bei jeder Neuanmeldung bei selfhost.de registriert (meine Fritzbox kann das). Wenn selfhost.de nicht in Frage kommt, es gibt noch viele andere, aber selfhost.de hat den Vorteil, dass Du freie Wahl beim Domainnamen hast (andere Anbieter haben nur bestimmte Pools an Namen).
Nobbie
 
Posts: 10444
Joined: 09. March 2008 13:04

Re: apache2 erreichbar, aber Unterverzeichnis nicht

Postby Simon2018 » 27. January 2018 18:52

Danke, ich habe bei domainssaubillig.de eine Domain gebucht, dort kann ich frame und Header-Weiterleitung einrichten. Ich habe dort einfach
http://portmapper.myonlineportal.net:XXXXX/
eingetragen.

Wie gesagt kann ich über die IPv4-Adresse im lokalen Netzwerk, über den Alias
* raspberrypi.local und
* über den Portmapper unter http://portmapper.myonlineportal.net:XXXXX/owncloud
meine owncloud Installation erreichen, nur über
* XXX.de/owncloud (wobei XXX.de ja auf http://portmapper.myonlineportal.net:XXXXX verweist) klappt es nicht.

Selfthost.de hilft mir nicht weiter, weil die kein Portmapping anbieten. Dank DS Lite kann ich den raspberry, auf dem der apache läuft, nur über seine IPv6 ansprechen. Eine Weiterleitung auf die IPv4 des Routers funktioniert nicht!
Simon2018
 
Posts: 4
Joined: 26. January 2018 22:48
XAMPP version: 2.4
Operating System: Windows / raspbian

Re: apache2 erreichbar, aber Unterverzeichnis nicht

Postby Nobbie » 27. January 2018 19:54

Simon2018 wrote:* XXX.de/owncloud (wobei XXX.de ja auf http://portmapper.myonlineportal.net:XXXXX verweist) klappt es nicht.


Weil Du im Frame auf eine IP weiterleitest, anstatt auf raspberrypi.local (was ja auch nicht funktionieren würde). Aber Apache ist offensichtlich so konfiguriert, dass für die IP ein anderer "VirtualHost" aktiv ist als für raspberrypi.local. Mit unterschiedlichem DocumentRoot und nur in einem der beiden DocumentRoot liegt das Verzeichnis Owncloud.

Das ist mit ziemlicher Sicherheit Dein Problem, aber ich bekomme ja selbst auf Nachfrage hier nicht gezeigt, wie raspberrypi.local definiert ist in Apache und worauf Du im Frame weiterleitest. Mehr kann ich Dir dazu nicht sagen, hier stecken alle Informationen drin, die Du brauchst, Du musst es jetzt nur umsetzen.
Nobbie
 
Posts: 10444
Joined: 09. March 2008 13:04

Re: apache2 erreichbar, aber Unterverzeichnis nicht

Postby Simon2018 » 27. January 2018 22:14

Nobbie wrote:Aber Apache ist offensichtlich so konfiguriert, dass für die IP ein anderer "VirtualHost" aktiv ist als für raspberrypi.local. Mit unterschiedlichem DocumentRoot und nur in einem der beiden DocumentRoot liegt das Verzeichnis Owncloud.

Und wie kann ich das nachsehen? In der apache.conf steht nichts darüber drin.
Im Verzeichnis /etc/apache2 liegen folgende Dateien:
apache2.conf conf-available conf-enabled envvars magic mods-available mods-enabled ports.conf sites-available sites-enabled
in sites-availble liegt dann die owncloud.conf Dort steht dann drin:

Code: Select all
<Directory /var/www/html/owncloud/>
 Options +FollowSymlinks
 AllowOverride All

<IfModule mod_dav.c>
 Dav off
 </IfModule>

SetEnv HOME /var/www/html/owncloud
 SetEnv HTTP_HOME /var/www/html/owncloud

</Directory>



Hier mal der aus meiner Sicht wichtigste Part aus apache2.conf:

Code: Select all
<Directory />
        Options FollowSymLinks
        AllowOverride None
        Require all denied
</Directory>

<Directory /usr/share>
        AllowOverride None
        Require all granted
</Directory>

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>



Nobbie wrote:Das ist mit ziemlicher Sicherheit Dein Problem, aber ich bekomme ja selbst auf Nachfrage hier nicht gezeigt, wie raspberrypi.local definiert ist in Apache und worauf Du im Frame weiterleitest. Mehr kann ich Dir dazu nicht sagen, hier stecken alle Informationen drin, die Du brauchst, Du musst es jetzt nur umsetzen.


Wie bereits geschrieben wurde raspberry.local nicht definiert und es wäre auch egal. .local ist einfach nur ein Verweis auf das Heimnetzwerk. Das spielt aber auch keine Rolle, denn über den Portmapper komme ich ja von extern auf meine Owncloud-Installation.
XXX.de verweist auf http://portmapper.myonlineportal.net:XXXXX (wobei XXX mein domainname ist und XXXXX ein Port, den man bei dem portmapper service frei wählen kann. Das hat erst mal nichts mit meinem Port zu tun, sonder ist nur der port von myonlineportal.net.
Simon2018
 
Posts: 4
Joined: 26. January 2018 22:48
XAMPP version: 2.4
Operating System: Windows / raspbian


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests