Problem mit virtualhost und .htaccess

Alles, was den Apache betrifft, kann hier besprochen werden.

Problem mit virtualhost und .htaccess

Postby nimmini » 19. September 2017 19:47

Hallo!

Ich betreibe einen Apache 2.4 auf einer openSUSE. Ich habe neben anderen einen Virtualhost konfiguriet, der die .htaccess nicht richtig auswertet.

require user andreas
AuthType Basic
AuthName Management
AuthUserFile /etc/users/andreasmd5.pwd

#<Files *>
#Require all denied
#</Files>

Ich bekomme einfach kein Authentifizierungsfenster. Entferne ich die Kommtarzeichen in der files-Sektion, erhalte ich einen Zugriff verweigert.
Auch ein
<ifModule mod_authz_core.c>
Require all denied
</ifModule>

in einer .htaccess in einem Testverzeichnis wird nicht ausgewertet.

Warum funktioniert

<Files *>
Require all denied
</Files>

und

require user andreas
AuthType Basic
AuthName Management
AuthUserFile /etc/users/andreasmd5.pwd

nicht? Die require user andreas funktioniert im Hauptserver mittels httpd.conf.local prolemlos.

Hat jemand Rat?

Grüße

Andreas
nimmini
 
Posts: 4
Joined: 28. August 2015 15:07
Operating System: Linux

Re: Problem mit virtualhost und .htaccess

Postby Nobbie » 19. September 2017 21:22

Wo hast Du die Syntax her, die "require user ..." Anweisung in die erste Zeile zu schreiben?? Habe ich noch nie so gesehen. Ich kenne sie nur nur unterhalb der Auth.... Anweisungen, also konkret unter AuthUserFile /etc/users/andreasmd5.pwd

Falls das nicht der Grund ist (ich weiß es wirklich nicht, finde es aber komisch), dann ist auch sehr gut möglich, dass die Datei /etc/user/andreasmd5.pwd für Apache nicht lesbar ist, das Verzeichnis ist jedenfalls extrem dubios gewählt. Überprüfe mit welcher UserID Apache läuft und ob dieser User diese Datei überhaupt lesen kann.
Nobbie
 
Posts: 9817
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests