default-ssl.conf

Alles, was den Apache betrifft, kann hier besprochen werden.

default-ssl.conf

Postby Oneiros » 27. June 2017 16:40

Grüßt euch,

ich habe via letsencrypt mehrere SSL-Zertifikate für mehrere V-Hosts eingerichtet, welche auch alle entsprechend funktionieren.
Jeder V-Host hat eine eigene Konfigurationsdatei mit dem Schema vhost_name.conf
Jetzt möchte ich jedoch, dass per Direktaufruf meiner IP-Adresse nicht mehr der Webroot erreicht wird, sondern eine Umleitung auf einen bestimmten V-Host erfolgt.
Aktuell erfolgt jedoch leider immer bei Aufruf der IP (egal ob http oder https) eine Umleitung auf den ersten, existenten V-Host, welcher auf ein nicht-gültiges Zertifikat hinweißt, da dieses auf Subdomain.Domain.TLD ausgestellt ist, statt auf die IP meines Servers.
Die Lösung des Problems sehe ich in entsprechender Anpassung der default-configs, jedoch weiß ich nicht, was ich zusätzlich einstellen müsste?

Die 000-default.conf:
Code: Select all
<VirtualHost *:80>

        ServerName domain.tld
        ServerAlias domain.tld
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html/

        <Directory /var/www/html/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order Deny,Allow
                Deny from all
                Options None
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>


Die default-ssl.conf
Code: Select all
<IfModule mod_ssl.c>
   <VirtualHost _default_:443>
      ServerAdmin webmaster@localhost
      DocumentRoot /var/www/html/contao
      ServerName domain.tld
      ServerAlias www.domain.tld
      

      ErrorLog ${APACHE_LOG_DIR}/error.log
      CustomLog ${APACHE_LOG_DIR}/access.log combined

      
      SSLEngine on

      
      SSLCertificateFile   /etc/letsencrypt/live/domain.tld/fullchain.pem
      SSLCertificateKeyFile /etc/letsencrypt/live/domain.tld/privkey.pem


      <FilesMatch "\.(cgi|shtml|phtml|php)$">
            SSLOptions +StdEnvVars
      </FilesMatch>
      <Directory /usr/lib/cgi-bin>
            SSLOptions +StdEnvVars
      </Directory>

      
      BrowserMatch "MSIE [2-6]" \
            nokeepalive ssl-unclean-shutdown \
            downgrade-1.0 force-response-1.0
      BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown

   </VirtualHost>
</IfModule>


Domain.tld ist selbstverständlich angepasst auf meine entsprechende Domain.

Kann mir diesbezüglich jemand weiterhelfen? :)
Der Certbot (webroot) muss natürlich weiterhin in der Lage sein, den Ordner .well_known im Webroot für die Auth-challenges zu erreichen.
Vielen Dank!

Grüße
Alex
Oneiros
 
Posts: 2
Joined: 27. June 2017 16:17
XAMPP version: 2.4
Operating System: Ubuntu 16.04

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests