Apache / Debian - Unterverzeichnisse funktionieren nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache / Debian - Unterverzeichnisse funktionieren nicht

Postby TheMrApostel » 22. February 2017 19:08

Hallo zusammen,

ich habe aktuell das Problem, dass meine Unterverzeichnisse nicht funktionieren d.h. der Textinhalt wird angezeigt, aber kein PHP ausgeführt.
Die Startseite von Apache funktioniert, aber sobald ich in ein Unterverzeichnis wechsle, funktioniert nichts mehr.
Mittlerweile habe ich einiges versucht und viele verschiedene Optionen einfach eingetragen. Leider ohne erfolg.
Folgend einmal die 000-default.conf:

Code: Select all
<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride all
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order Deny,Allow
                Allow from 127.0.0.1
                Allow from localhost
                Deny from all
        </Directory>
        Alias /admin /var/www/admin
        <Directory /var/www/admin/>
                Options All
                AllowOverride All
                order allow,deny
                allow from all
        </Directory>

        Alias /nextcloud /var/www/nextcloud
        <Directory /var/www/nextcloud/>
                Options All
                AllowOverride All
                order allow,deny
                allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>


Das Root Verzeichnis ist /var/www. Dies habe ich einmal von /var/www/html auf /var/www abgeändert. Sobald ich etwas im Rootverzeichnis ablege, funktioniert alles ohne Probleme.
Sobald wir ein Unterverzeichnis ansprechen, ist es vorbei.
In meiner Apache.conf habe ich folgende Verzeichnisse definiert:

Code: Select all
<Directory />
        Options FollowSymLinks
        AllowOverride None
        Require all denied
</Directory>

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>


Vielleicht hat jemand von euch eine zündende Idee?

Vielen Dank und beste Grüße,
Maxe
TheMrApostel
 
Posts: 1
Joined: 22. February 2017 18:59
Operating System: Linux Debian

Re: Apache / Debian - Unterverzeichnisse funktionieren nicht

Postby Nobbie » 22. February 2017 22:41

TheMrApostel wrote:Die Startseite von Apache funktioniert, aber sobald ich in ein Unterverzeichnis wechsle, funktioniert nichts mehr.


Stelle Dir vor, ich würde Dir genau diese Frage stellen - wie würdest Du antworten? BIst Du der Meinung, dass das eine Fehler- oder Situationsbeschreibung ist, aus der man (als Außenstehender) irgendetwas erkennen kann?

TheMrApostel wrote:Mittlerweile habe ich einiges versucht und viele verschiedene Optionen einfach eingetragen. Leider ohne erfolg.


Und noch einmal, s.o.: was wäre Deine zündende Idee, wenn jemand erklärt, dass er "ohne Erfolg" ist. Was könnte die Ursache sein, woran würdest Du die Ursache festmachen?

TheMrApostel wrote:Folgend einmal die 000-default.conf:


Kommentiere doch mal bitte diejenigen Zeilen, die Du selbst eingetragen hast, warum Du sie eingetragen hast und was Du Dir im einzelnen davon versprochen hast. Da wir sowieso nicht wissen, ob die Konfiguration überhaupt für den Fehler (a propos: welcher Fehler? Siehst Du irgendeine Beschreibung, die irgendetwas konkret darstellt?) verantwortlich ist, ist das recht schwieirig, wo soll ich hinschauen?

Also welche Ideen hättest Du? Nur mal als Beispiel: jemand sagt zu Dir, ich habe erfolglos versucht, mit meinem Auto zu fahren - welche zündende Idee hättest Du, warum das mit dem Fahren nicht geklappt hat?

Um mal mehr Beispiele zu geben: zwei Freunde sprechen Dich getrennt voneinander an, beide erzählen, sie hätten Probleme mit ihrem Auto. Der erste erzählt Dir, er hätte alle möglichen Optionen versucht, aber leider ohne Erfolg. Er gibt Dir die Wagenpapiere, um den Fehler zu finden. Welche zündende Idee hättest Du? Der andere erzählt, er wäre mit leerer Batterie und mit leerem Tank nach Hause gekommen, er hat die Garagen noch so gerade erreicht. Dann hätte er mit einem Ladegerät die Batterie geladen und außerdem hätte er 50l Wasser in den Tank gekippt. Danach hätte er probiert, den Wagen zu starten, aber es hätte nicht funktioniert, der Motor wäre nicht angesprungen. Das Licht war da, aber irgendwie wollte der Motor nicht. Hättest Du vielleicht bei diesem Freund eine zündende Idee, was er vielleicht besser anders gemacht hätte? Und wenn ja - wieso hast Du eine Idee? Was ist denn anders als mit dem ersten Freund, der hat doch auch "alle möglichen Optionen" versucht. Und dennoch kannst Du nicht beiden gleich helfen. Warum nur?
Nobbie
 
Posts: 9770
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests