apache 2.2 mit +SSLv2 und OPENSSL 1.0.1 startet nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

apache 2.2 mit +SSLv2 und OPENSSL 1.0.1 startet nicht

Postby thomasre74 » 11. September 2016 10:27

hi,

ich versuche für eine demo einen apachen mit sslv2 aufzusetzen, was mir leider nicht gelingt.
ich verwende eine raspberry mit jessie und habe den apachen 2.2 aus den wheezy rep installiert.
openssl habe ich 1.0.1 kompiliert und direkt an folgene location kopiert (ssl:mod zieht diese laut ldd an).

/usr/lib/arm-linux-gnueabihf/libssl.so.1.0.0
/usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.0

verwenden tut der apache sie, das erkennt man z.b. daran das der apache jetzt auch für heartbleed anfällig ist.
diese openssl version hat SSLV2 noch per default reinkompiliert.

wenn ich jedoch jetzt in der ssl.conf v2 mit +SSLv2 aktiviere, startet der apache nicht mit der fehlermeldung im syslog

apache2[2836]: SSLv2 not supported by this version of OpenSSL

jetzt bin ich dann etwas ratlos und für jeden tipp dankbar.

lg! thomas.
thomasre74
 
Posts: 1
Joined: 11. September 2016 09:58
XAMPP version: no
Operating System: pi

Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests