Apache doesn't update IP address for URL even DNS has update

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache doesn't update IP address for URL even DNS has update

Postby kendarkfire » 23. August 2016 20:09

we have an AWS Internal LB domain, and in Apache, we set up apache mod_proxy to that domain, it works fine when Apache just started, but the IP of that LB domain will be changed later, then Apache didn't update the IP and it always failed to connect to that LB. then if we restart the Apache, it will work again;

I think Apache mod_proxy only parse domain through DNS when starting up, after Apache started, even the IP address of the domain has been changed and the DNS server has updated it, but Apache didn't update it;

is there any solution for this issue?

ProxyPass / http://xxx.internal-xxxamazon.com/
ProxyPassReverse / http://xxx.internal-xxxamazon.com/
kendarkfire
 
Posts: 2
Joined: 23. August 2016 20:05
XAMPP version: 2.4
Operating System: ubuntu

Re: Apache doesn't update IP address for URL even DNS has up

Postby kendarkfire » 24. August 2016 01:02

By reading the detail document on https://httpd.apache.org/docs/current/mod/mod_proxy.html#proxypass;
I found the solution by adding the following parameter for proxypass:

ProxyPass / http://spd2.noosh.com/ disablereuse=on

the description of that parameter is:

This parameter should be used when you want to force mod_proxy to immediately close a connection to the backend after being used, and thus, disable its persistent connection and pool for that backend. This helps in various situations where a firewall between Apache httpd and the backend server (regardless of protocol) tends to silently drop connections or when backends themselves may be under round- robin DNS. To disable connection pooling reuse, set this property value to On.
kendarkfire
 
Posts: 2
Joined: 23. August 2016 20:05
XAMPP version: 2.4
Operating System: ubuntu


Return to Apache

Who is online

Users browsing this forum: No registered users and 1 guest