Apach startet wegen vhost nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Apach startet wegen vhost nicht

Postby robbyn » 17. August 2016 09:58

Hallo Leute,
ich wollte einen vhost einrichten unter Windows 10 (XAMPP Version: 5.6.23), aber der Apache Server startet dann nicht. Nehme ich meine vhost Einstellungen aus der httpd-vhosts.conf Datei wieder raus, startet der Server ganz normal.

Hier mein Error Log:

Code: Select all
[Wed Aug 17 10:30:17.508776 2016] [ssl:warn] [pid 12668:tid 548] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Aug 17 10:30:17.535809 2016] [core:warn] [pid 12668:tid 548] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Aug 17 10:30:17.606857 2016] [ssl:warn] [pid 12668:tid 548] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Aug 17 10:30:17.846978 2016] [mpm_winnt:notice] [pid 12668:tid 548] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.23 configured -- resuming normal operations
[Wed Aug 17 10:30:17.846978 2016] [mpm_winnt:notice] [pid 12668:tid 548] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Wed Aug 17 10:30:17.846978 2016] [core:notice] [pid 12668:tid 548] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Aug 17 10:30:17.854984 2016] [mpm_winnt:notice] [pid 12668:tid 548] AH00418: Parent: Created child process 9760
[Wed Aug 17 10:30:18.238171 2016] [ssl:warn] [pid 9760:tid 516] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Aug 17 10:30:18.334183 2016] [ssl:warn] [pid 9760:tid 516] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Aug 17 10:30:18.360197 2016] [mpm_winnt:notice] [pid 9760:tid 516] AH00354: Child: Starting 150 worker threads.


Vielen Dank für eure Hilfe!
robbyn
 
Posts: 2
Joined: 17. August 2016 09:54
XAMPP version: 5.6.23
Operating System: Windows 10

Re: Apach startet wegen vhost nicht

Postby Altrea » 17. August 2016 21:29

Hallo,

Ohne die VHost Konfiguration zu kennen ist es unmöglich etwas einzuschätzen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apach startet wegen vhost nicht

Postby robbyn » 25. August 2016 10:59

Hey, vielen Dank für dein Feedback.

Hier die vhost bzw. den Abschnitt den ich eingefügt habe, den Rest habe ich nicht verändert (ist ja eh alles anderes auskommentiert)

Code: Select all

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
    ServerName test.de
    DocumentRoot "C:/Entwicklung/test/web/"
    DirectoryIndex index.php index.html
    <Directory "C:/Entwicklung/test/web/">
        AllowOverride All
        Allow from All
          Options +Indexes
    </Directory>
    ErrorLog "logs/error_log"
</VirtualHost>
robbyn
 
Posts: 2
Joined: 17. August 2016 09:54
XAMPP version: 5.6.23
Operating System: Windows 10


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests