Problem mit SSL (->403 Forbidden)

Alles, was den Apache betrifft, kann hier besprochen werden.

Problem mit SSL (->403 Forbidden)

Postby Echapa » 02. March 2016 21:45

Hallo!
Ich versuche für Owncloud SSL mit Apache ans laufen zu bekommen. Ich habe mich dafür an diese Anleitung
gehalten (http://xmodulo.com/install-configure-owncloud-debian.html).
Ich glaube, dass ich die Zertifikate korrekt erstellt habe. Aber wenn ich versuche, auf das Webinterface zu zugreifen,
bekomme ich immer den Fehler 403:

Forbidden

You don't have permission to access /owncloud/ on this server.


Das ist meine owncloud.conf - Datei. Die hatte ich schon versucht an
zupassen, weil deren Datei für mich nicht funktioniert hat.

<VirtualHost *:443>
SSLEngine on
SSLCertificateFile /etc/apache2/ssl/apache.crt
SSLCertificateKeyFile /etc/apache2/ssl/apache.key

ServerAdmin [hier steht meine Mail Addresse]
ServerName localhost


DocumentRoot /var/www/owncloud

</VirtualHost>


Die index.php liegt auf jeden Fall in "/var/www/owncloud".

Apache startet an sich, gibt mit aber folgende Ausgabe:

owncloud apache2[5021]: Starting web server: apache2AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message


Betriebssystem: Debian 8
Apache Version: 2.4.2
OpenSSL: 1.0.1k
Owncloud: 8.1.5

Vielen Dank!

Christoph
Echapa
 
Posts: 2
Joined: 02. March 2016 21:29
Operating System: Debian

Re: Problem mit SSL (->403 Forbidden)

Postby Nobbie » 03. March 2016 10:48

Error 403 bedeutet in aller Regel eine fehlende oder falsche "Require" Klausel (in alten Apache Versionen war das "Allow From"). In der Tat steht auch in der VirtualHost Angabe kein Wort dazu, mit welchen Zugriffsrechten /var/www/owncloud ausgestattet ist. Eine gängige Klausel (als Beispiel), die jeglichen Zugriff erlaubt, lautet "Require All Granted". Andere Varianten schränken beispielsweise den Zugriff auf bestimmte IPs ein oder ähnlich, aber hier steht definitiv gar nichts und das kann bedeuten (das hängt davon ab, ob ggf. an einer anderen Stelle etwas festgelegt wurde), dass auch gar nichts erlaubt ist und das führt unweigerlich zu Error 403. Mit SSL an sich hat das überhaupt nichts zu tun.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Problem mit SSL (->403 Forbidden)

Postby Echapa » 05. March 2016 10:00

Ich danke dir schonmal vielmals für deine Antwort!
Nobbie wrote:Error 403 bedeutet in aller Regel eine fehlende oder falsche "Require" Klausel (in alten Apache Versionen war das "Allow From"). In der Tat steht auch in der VirtualHost Angabe kein Wort dazu, mit welchen Zugriffsrechten /var/www/owncloud ausgestattet ist.


Ich habe auf deinen Hinweis hin die Datei "/etc/apache2/conf-enabled/owncloud.conf" so angepasst:

<VirtualHost *:443>
SSLEngine on
SSLCertificateFile /etc/apache2/ssl/apache.crt
SSLCertificateKeyFile /etc/apache2/ssl/apache.key

ServerAdmin christoph.p@t-online.de
ServerName localhost


DocumentRoot /var/www/owncloud

<Directory "/var/www/owncloud">
AllowOverride All
Require all granted
</Directory>


</VirtualHost>


Leider führt das zu keiner Änderung. Kann es sein, dass der Zugriff an anderer Stelle verweigert wird? Ich habe mir mal die
"Apache GUI" installiert. Ich bin ein wenig verwirrt, denn die "owncloud.conf" gibt es an mehreren Orten. Z.B. "conf-available"
oder "conf-enabled". In "sites-available" oder "sites-enabled" ist sie z.B. nicht zu finden. Könnte das der Punkt sein?

In "sites-enabled" gibt es auch eine "default-ssl.conf". Da ich ja über SSL verbinden will. Müsste dann dort nicht auch eine
"owncloud.conf" sein? Ist jetzt nur ein Gedanke aus meinem extrem beschränkten Know-How heraus.

Jeder weitere Hinweis ist extrems willkommen.

Christoph
Echapa
 
Posts: 2
Joined: 02. March 2016 21:29
Operating System: Debian


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests