Rewrite mit htaccess bringt Forbidden Fehler

Alles, was den Apache betrifft, kann hier besprochen werden.

Rewrite mit htaccess bringt Forbidden Fehler

Postby trprivat » 02. September 2004 21:37

Hallo zusammen,

wenn ich die folgende htaccess Datei ins homedir lege erhalten ich immer der Forbidden Fehler.

RewriteEngine On
RewriteBase /
RewriteRule profil\.htm$ profil\.php
RewriteRule ^(profil)([0-9]{2}).htm$ /$1.php?kennziffer=$2

dann kommt bei Aufrauf der Hauptseite schon:

Forbidden
You don't have permission to access / on this server.
--------------------------------------------------------------------------------
Apache/1.3.23 Server at www.east-singles.de Port 80


Der rewrite mod ist auf on, aber so wie es aussieht muß ich noch igentwo Rechte vergeben.
Leider bin ich kein experte und suche schon seit Wochen nach einer Lösung. Der Server wird per Comfixx administriert.

Vielen Dank im Voraus

Thorsten
trprivat
 
Posts: 5
Joined: 02. September 2004 21:06

Postby Wiedmann » 03. September 2004 10:10

Dir fehlt ein:
Options +FollowSymLinks
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby trprivat » 03. September 2004 10:17

Könntest Du mir das bitte etwas mehr beschreiben?

An welcher Stelle sollte dass den stehen.

Sorry Newbie :wink:
trprivat
 
Posts: 5
Joined: 02. September 2004 21:06

Postby Wiedmann » 03. September 2004 10:27

Im einfachsten Fall kannst du das direkt in die ".htaccess" mit reinschreiben.

Oder du suchst in der "httpd.conf" nach der Options-Directive die für dein "/htdocs/"-Verzeichnis zuständig ist, und erweiterst die um "+FollowSymLinks"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby trprivat » 03. September 2004 10:40

Ich habe es so gemacht

RewriteEngine On
RewriteBase /
RewriteRule profil\.htm$ profil\.php
RewriteRule ^(profil)([0-9]{2}).htm$ /$1.php?kennziffer=$2
Options +FollowSymLinks

Jetzte erhalte ich folgenden Fehler:

Serverfehler!
Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist. Der Server ist entweder überlastet oder ein Fehler in einem CGI-Skript ist aufgetreten.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 500
www.2lonelyhearts.de
Fri Sep 3 11:31:02 2004
Apache/2.0.48 (Linux/SuSE)


Wie gesagt fäuft der Server unter Confixx 3, kann ich da etwas im httpd Spezial eintragen? Dort habe ich auch den Save_Mode ausgeschaltet.
trprivat
 
Posts: 5
Joined: 02. September 2004 21:06

Postby Wiedmann » 03. September 2004 10:57

Jetzte erhalte ich folgenden Fehler:
...
Error 500

Dann fehlt dir ein "AllowOverride Options" um "Options" in einer ".htaccess" benutzen zu können. (Oder du nimmst halt meine 2. Methode und schreibst es direkt in die "httpd.conf")

Wie man den Apache mit Confixx administriert kann ich dir leider nicht sagen. Da muss jemand anderes etwas dazu beitragen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby trprivat » 03. September 2004 12:14

Tja, ich habe es mal über das httpd Sezial von Confixx probiert, hat aber leider nicht funktioniert. Gleicher Fehle sobald ich die htaccess ins homedir schiebe.

Wo liegt den die httpd.conf unter Suse?
Ich scheue mich etwas davor, per root Änderungen vorzunehmen, da man wissen sollte was man tut und dass weiß ich nicht wirklich :wink:

Ich kann gerade noch mc eingeben und damit etwas umgehen.

Ich habe es jetzt auch einmal auf 2 anderen Server ausprobiert, dort klappt es auch nicht. Diese hatten aber noch Apache 1.3.
trprivat
 
Posts: 5
Joined: 02. September 2004 21:06


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests