Apache shutdown unexpectedly

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache shutdown unexpectedly

Postby h.niger » 30. December 2015 23:57

Not sure what is going on. Apache was working fine and then I got this message so I uninstalled and reinstalled XAMPP but the issue persists. Any assistance would be appreciated.

Apache settings:
Main: 80
SSL: 443


Netstal Listening Sockets:
Port: 80 PID: 10252 httpd.exe


Log Windows says:
Attempting to start Apache app...
5:47:13 PM [mysql] Autostart aborted: MySQL is already running
5:47:13 PM [filezilla] Autostart aborted: FileZilla is already running
5:47:13 PM [Apache] Status change detected: running
5:47:15 PM [Apache] Status change detected: stopped
5:47:15 PM [Apache] Error: Apache shutdown unexpectedly.
5:47:15 PM [Apache] This may be due to a blocked port, missing dependencies,
5:47:15 PM [Apache] improper privileges, a crash, or a shutdown by another method.
5:47:15 PM [Apache] Press the Logs button to view error logs and check
5:47:15 PM [Apache] the Windows Event Viewer for more clues
5:47:15 PM [Apache] If you need more help, copy and post this
5:47:15 PM [Apache] entire log window on the forums


error.log says:
[Wed Dec 30 15:59:08.197899 2015] [ssl:warn] [pid 10252:tid 524] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Dec 30 15:59:08.512730 2015] [ssl:warn] [pid 10252:tid 524] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Dec 30 15:59:08.711875 2015] [mpm_winnt:notice] [pid 10252:tid 524] AH00455: Apache/2.4.17 (Win32) OpenSSL/1.0.2d PHP/5.6.15 configured -- resuming normal operations
[Wed Dec 30 15:59:08.711875 2015] [mpm_winnt:notice] [pid 10252:tid 524] AH00456: Apache Lounge VC11 Server built: Oct 13 2015 10:54:13
[Wed Dec 30 15:59:08.711875 2015] [core:notice] [pid 10252:tid 524] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Dec 30 15:59:08.724376 2015] [mpm_winnt:notice] [pid 10252:tid 524] AH00418: Parent: Created child process 6500
[Wed Dec 30 15:59:10.165468 2015] [ssl:warn] [pid 6500:tid 632] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Dec 30 15:59:10.494069 2015] [ssl:warn] [pid 6500:tid 632] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Dec 30 15:59:10.597360 2015] [mpm_winnt:notice] [pid 6500:tid 632] AH00354: Child: Starting 150 worker threads.
h.niger
 
Posts: 2
Joined: 30. December 2015 18:51
Operating System: Windows 10

Re: Apache shutdown unexpectedly

Postby Nobbie » 31. December 2015 09:19

Netstal Listening Sockets:
Port: 80 PID: 10252 httpd.exe


That means, Apache is up and running. Apache = httpd.exe

Maybe you opted Apache for starting up automatically at boot time or so?! Simply enter localhost into your browser, it should show Apache running.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Apache shutdown unexpectedly

Postby h.niger » 31. December 2015 16:24

Hi Noobie,

Thanks for you assistance.

I understand the Netstat window says Apache is running and when I type localhost into the browser it takes me to a localhost/dashboard page that says "Welcome To XAMPP for Windows".

The problem is that I keep getting this message when I start XAMPP:

10:00:58 AM [main] Initializing Control Panel
10:00:58 AM [main] Windows Version: Home 64-bit
10:00:58 AM [main] XAMPP Version: 5.5.30
10:00:58 AM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
10:00:58 AM [main] You are not running with administrator rights! This will work for
10:00:58 AM [main] most application stuff but whenever you do something with services
10:00:58 AM [main] there will be a security dialogue or things will break! So think
10:00:58 AM [main] about running this application with administrator rights!

10:00:58 AM [main] XAMPP Installation Directory: "c:\xampp\"
10:00:58 AM [main] Checking for prerequisites
10:01:00 AM [main] All prerequisites found
10:01:00 AM [main] Initializing Modules
10:01:00 AM [Apache] Problem detected!
10:01:00 AM [Apache] Port 80 in use by "Unable to open process" with PID 7348!
10:01:00 AM [Apache] Apache WILL NOT start without the configured ports free!
10:01:00 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:01:00 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port

10:01:00 AM [main] Starting Check-Timer
10:01:00 AM [main] Control Panel Ready
10:01:49 AM [Apache] Problem detected!
10:01:49 AM [Apache] Port 80 in use by "Unable to open process" with PID 7348!
10:01:49 AM [Apache] Apache WILL NOT start without the configured ports free!
10:01:49 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:01:49 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:01:49 AM [Apache] Attempting to start Apache app...
10:01:49 AM [Apache] Status change detected: running
10:01:50 AM [Apache] Status change detected: stopped
10:01:50 AM [Apache] Error: Apache shutdown unexpectedly.
10:01:50 AM [Apache] This may be due to a blocked port, missing dependencies,
10:01:50 AM [Apache] improper privileges, a crash, or a shutdown by another method.
10:01:50 AM [Apache] Press the Logs button to view error logs and check
10:01:50 AM [Apache] the Windows Event Viewer for more clues
10:01:50 AM [Apache] If you need more help, copy and post this
10:01:50 AM [Apache] entire log window on the forums



When I try press start Apache will not connect to the port that it says it is already connected to. Instead the above message displays.
h.niger
 
Posts: 2
Joined: 30. December 2015 18:51
Operating System: Windows 10

Re: Apache shutdown unexpectedly

Postby Nobbie » 31. December 2015 21:43

h.niger wrote:The problem is that I keep getting this message when I start XAMPP:
....

When I try press start Apache will not connect to the port that it says it is already connected to. Instead the above message displays.


Yes of course, because Apache (httpd.exe) is already started and you cannot start it twice. As i already said "Maybe you opted Apache for starting up automatically at boot time or so?!".
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Apache shutdown unexpectedly

Postby Altrea » 31. December 2015 23:38

Start the control panel with enhanced administration rights (rightclick -> run as administrator) and all these messages will be fine.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests