Apache fails to work when IP address is entered in browser

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache fails to work when IP address is entered in browser

Postby tcnm » 29. December 2015 20:44

I installed and started apache 2.2.31 on Linux Ubuntu 15.10. When i enter my loopback id (127.0.0.1) in my browser, the correct message ("It works") appears, but, when i enter my site ip address (71.187.235.187) in the browser, I receive the message: "Firefox can't establish a connection to the server at 71.187.235.187."
Note that the directive "Listen" is set to 80.

The following commands and responses may be relevant:

root@pegasus:/proc# nc -zv 127.0.0.1 80 // Trying to access the loopback ID
Connection to 127.0.0.1 80 port [tcp/http] succeeded!
root@pegasus:/proc# nc -zv 71.187.235.187 80 // Trying to access the site ID
nc: connect to 71.187.235.187 port 80 (tcp) failed: No route to host
tcnm
 
Posts: 1
Joined: 29. December 2015 20:21
Operating System: Linux ubuntu

Re: Apache fails to work when IP address is entered in brows

Postby Nobbie » 29. December 2015 21:20

tcnm wrote:root@pegasus:/proc# nc -zv 71.187.235.187 80 // Trying to access the site ID
nc: connect to 71.187.235.187 port 80 (tcp) failed: No route to host


This means, that even TCPIP cannot find your IP. It is not an Apache problem, maybe a firewall problem or anything else.
Nobbie
 
Posts: 8769
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests