Proxy Einstellung liefert 404

Alles, was den Apache betrifft, kann hier besprochen werden.

Proxy Einstellung liefert 404

Postby waldwolf » 07. May 2015 14:34

Hallo liebe Gemeinde,
ich möchte gerne meine Jirainstallation über die URL priv.jira-mgh.de aufrufen.
Jira ist unter localhost:8080 erreichbar. Die Konfiguration leitet auch erfolgreich auf http://priv.jira-mgh.de/secure/MyJiraHome.jspa um.

Ich habe mich durch die Bedienungsanleitung im Internet gehangelt und habe folgende VirtualHost Einstellungen:
Code: Select all
<VirtualHost *:80>
    ServerName priv.jira-mgh.de
    ServerAlias priv.jira-mgh.de
ProxyPreserveHost On
        ProxyRequests Off
        ProxyPass / http://localhost:8080/
        ProxyPassReverse / http://localhost:8080/
<Proxy *>
  Require all granted
    </Proxy>


</VirtualHost>
   


Leider erhalte ich immer einen 404 Fehler das die Seite nicht gefunden wurde.

apache2ctl -S liefert folgendes.
[Thu May 07 15:32:30.720366 2015] [proxy_html:notice] [pid 12375] AH01425: I18n support in mod_proxy_html requires mod_xml2enc. Without it, non-ASCII characters in proxied pages are likely to display incorrectly.
VirtualHost configuration:
*:80 is a NameVirtualHost
default server mgh.de (/etc/apache2/sites-enabled/mgh.de.conf:1)
port 80 namevhost mgh.de (/etc/apache2/sites-enabled/mgh.de.conf:1)
port 80 namevhost priv.jira-mgh.de (/etc/apache2/sites-enabled/priv.jira-mgh.de.conf:1)
alias priv.jira-mgh.de
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex proxy: using_defaults
Mutex default: dir="/var/lock/apache2" mechanism=fcntl
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="www-data" id=33 not_used
Group: name="www-data" id=33 not_used


mod_proxy und mod_proxy_html sind aktiviert.
Meine Apacheversion:
$ apache2 -version
Server version: Apache/2.4.7 (Ubuntu)
Was habe ich falsch gemacht? Kann mir jemand helfen?
waldwolf
 
Posts: 2
Joined: 07. May 2015 14:26
Operating System: Ubuntu 14.04

Re: Proxy Einstellung liefert 404

Postby Nobbie » 07. May 2015 18:15

>Leider erhalte ich immer einen 404 Fehler das die Seite nicht gefunden wurde.

Bitte keine verstümmelten Prosameldungen - bitte die komplette reale Fehlermeldung.

Was genau gibst Du im Browser ein?

Und was steht im Error Log?

Und wie sieht die Hosts Datei aus?
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Proxy Einstellung liefert 404

Postby waldwolf » 07. May 2015 18:47

Oh Mann :o :o
ich habe den hosts eintrag einfach vergessen.
Ewig gesucht und jetzt so schnell.
Danke jetzt läuft es.
waldwolf
 
Posts: 2
Joined: 07. May 2015 14:26
Operating System: Ubuntu 14.04


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests