directory listing unterbinden

Alles, was den Apache betrifft, kann hier besprochen werden.

directory listing unterbinden

Postby Deejoy » 17. August 2004 22:43

Hi,

ich möchte gerne das kein listing von Ornder ohne eine index.html oder index.php angezeigt wird.
Entsprechend habe ich folgendes in der httpd.conf eingetragen

Code: Select all
<VirtualHost xxx.de:80>
ServerName localhost
ServerAlias www.xxx.de yyy.info www.yyy.info
ServerAdmin info@xxx.de
DocumentRoot /opt/lampp/htdocs/xxx
<Directory " /opt/lampp/htdocs/xxx">
Options -Indexes
</Directory>
</VirtualHost>


Options -Indexes <--- das sollte doch nirmalerweise das listing verhindern oder !?
funktioniert leider bei mir nicht.

Habe XAMPP für Linux 1.4.7

Gruß Deejoy
Deejoy
 
Posts: 26
Joined: 15. July 2004 21:29

Postby JayDee » 18. August 2004 10:13

ich habe das nich im virtuellen Host, sondern in der Directrive <Directory>

probiere mal ....
Gruß
JayDee
(Webmaster Spielmannszug St. Mauritz-Erpho)

Image

oder auch www.strandchecker.de ;)
die etwas andere Strandseite
User avatar
JayDee
 
Posts: 36
Joined: 30. April 2004 11:57
Location: Münster

Postby Deejoy » 18. August 2004 12:18

Ja das habe ich mitlerweile auch gefunden.
Was mich daran jetzt nur stört ist das dies Übergreifend ist. Ich möchte es bei den einzelnen Host extra bestimmen. So das ich es bei einem an habe und bei anderen aus habe
Deejoy
 
Posts: 26
Joined: 15. July 2004 21:29

Postby JayDee » 18. August 2004 12:31

na soweit vorgdrungen bin ich auch noch nicth, mir ging erstmal darumm, dass nix angezeigt wird ...
Gruß
JayDee
(Webmaster Spielmannszug St. Mauritz-Erpho)

Image

oder auch www.strandchecker.de ;)
die etwas andere Strandseite
User avatar
JayDee
 
Posts: 36
Joined: 30. April 2004 11:57
Location: Münster

Postby Deejoy » 18. August 2004 12:52

Na dann werde ich mich wohl noch ein bischen durchtesten.
Deejoy
 
Posts: 26
Joined: 15. July 2004 21:29

Postby Wiedmann » 18. August 2004 16:42

<VirtualHost xxx.de:80>
ServerName localhost
ServerAlias www.xxx.de yyy.info www.yyy.info
ServerAdmin info@xxx.de
DocumentRoot /opt/lampp/htdocs/xxx
<Directory " /opt/lampp/htdocs/xxx">
Options -Indexes
</Directory>
</VirtualHost>


Dieses Leerzeichen zwischen " und / ist in deiner orginal Conf hoffentlich nicht drin? (die Doublequotes kannst du auch weglassen)

Ansonsten gibt es dann noch die Möglichkeit, dass dieser VHost gar nicht benutzt wird, oder das es auch noch eine ".htaccess" gibt die das wieder aufhebt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Deejoy » 18. August 2004 16:51

Ahhh Danke jetzt klappt es so wie ich es möchte.
Hatte mir das aus den optimale Hosteinstellunge rauskopiert , vielleicht habe ich mich da auch nur verschaut.
Deejoy
 
Posts: 26
Joined: 15. July 2004 21:29


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests