Autom. Weiterlg http –>https nach 8080 läuft und 8090 nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Autom. Weiterlg http –>https nach 8080 läuft und 8090 nicht

Postby herryeh » 12. November 2014 16:07

Hallo zusammen,

ich habe zwei virtuelle Hosts eingerichtet für zwei Programme unter zwei verschiedenen Tomcats. XamppTomcat nicht installiert.
Bei 8080 funktioniert alles wie gewünscht; Leitet wie gewünscht auf https weiter wenn über HTTP aufgerufen. https bei 8090 funktioniert auch - aber http nicht:
The requested URL xy was not found on this server.

Tausche ich die Ports ist es genau das gleiche. 8080 funktioniert 8090 nicht. Liegt also nicht an den Programmen denke ich.

Konfiguration in der virtuelle Hosts.Conf:

Code: Select all
<VirtualHost *:90>
    ServerAdmin webmaster@SERVERNAME
    DocumentRoot "C:/programs/apache/htdocs"
    ServerName SERVERNAME
       ServerAlias SERVERNAME

ProxyRequests     Off
ProxyPreserveHost On

ProxyPass         /prog2 http://SERVERNAME:8090/prog2
ProxyPassReverse  /prog2 http://SERVERNAME:8090/prog2

</VirtualHost>


<VirtualHost *:80>
    ServerAdmin webmaster@SERVERNAME
    DocumentRoot "C:/programs/apache/htdocs"
    ServerName SERVERNAME
       ServerAlias SERVERNAME
ProxyRequests     Off
ProxyPreserveHost On

ProxyPass         /prog http://SERVERNAME:8080/prog
ProxyPassReverse  /prog http://SERVERNAME:8080/prog

</VirtualHost>


ssl.conf

Code: Select all
<VirtualHost _default_:443>
    ServerName SERVERNAME
     
    SSLEngine           On
    SSLCertificateFile      "C:\OpenSSL-Win32\server.crt"
    SSLCertificateKeyFile   "C:\OpenSSL-Win32\server.key"
    SSLProxyEngine      On
         
    ProxyRequests       Off
    ProxyPreserveHost   On
 
    <Proxy *>
        Order deny,allow
        Allow from all
    </Proxy>
   
    ProxyPass       /prog2 http://SERVERNAME:8090/prog2
    ProxyPassReverse    /prog2 http://SERVERNAME:8090/prog2
       
    ProxyPass       /prog http://SERVERNAME:8080/prog
    ProxyPassReverse    /prog http://SERVERNAME:8080/prog
         
</VirtualHost>


Woran könnte es liegen?


Danke im Voraus

Olaf
herryeh
 
Posts: 2
Joined: 12. November 2014 14:45
Operating System: Windows 2008 Server r2

Re: Autom. Weiterlg http –>https nach 8080 läuft und 8090 ni

Postby Nobbie » 12. November 2014 20:00

herryeh wrote: Woran könnte es liegen?


An irgendeinem Fehler. Mehr ist bei dieser extrem spärlichen Information leider nicht drin. Wir sehen weder die URL, die eingegeben wird, noch die Seite, die "liefern" soll, ich sehe irgendetwas mit Port 80 und Port 90 (beides aber in der spärlichen Erklärung nicht erwähnt oder erläutert), hellsehen kann ich nicht - also ist wohl irgendwo etwas falsch.

Was genau wird überhaupt betrieben, wie heißen die Domains in Wirklichkeit, wie heißen die Server in Wirklichkeit und wie sieht vor allen Dingen die Konfiguration "in echt" aus? Pauschalisierte Abstraktkonfigurationen kann man nicht debuggen. Und last not least, was machst Du selbst damit? Was ist der Sinn, eine sehr ungewöhnliche Anforderung aus dem privaten Bereich?!
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Autom. Weiterlg http –>https nach 8080 läuft und 8090 ni

Postby herryeh » 13. November 2014 14:33

wie man es macht, macht man es verkehrt. Und wenn man sich nicht auskennt, muss man sich von denen, die sich auskennen ordentlich beschimpfen lassen, kapiert, alles klar.
also es geht um Jira und Confluence.

Hier die derzeitige Konfiguration auf meinem Test Server.

Virtueller host.conf
Code: Select all
<VirtualHost *:90>
    ServerAdmin webmaster@wikitest64
    DocumentRoot "C:/programs/apache/htdocs"
    ServerName wikitest64
       ServerAlias jira
    ErrorLog "logs/jirassl.dus.fact.prv-error.log"
    CustomLog "logs/jirassl.dus.fact.prv-access.log" common
ProxyRequests     Off
ProxyPreserveHost On

ProxyPass         /jira http://wikitest64:8090/jira
ProxyPassReverse  /jira http://wikitest64:8090/jira

</VirtualHost>


<VirtualHost *:80>
    ServerAdmin webmaster@wikitest64
    DocumentRoot "C:/programs/apache/htdocs"
    ServerName wikitest64
       ServerAlias confluence
    ErrorLog "logs/conf.dus.fact.prv-error.log"
    CustomLog "logs/confluence.dus.fact.prv-access.log" common
   
ProxyRequests     Off
ProxyPreserveHost On

ProxyPass         /confluence http://wikitest64:8080/confluence
ProxyPassReverse  /confluence http://wikitest64:8080/confluence

</VirtualHost>


ssl.conf

Code: Select all
<VirtualHost _default_:443>
    ServerName wikitest64
     
    SSLEngine           On
    SSLCertificateFile      "C:\OpenSSL-Win32\server.crt"
    SSLCertificateKeyFile   "C:\OpenSSL-Win32\server.key"
    SSLProxyEngine      On
         
    ProxyRequests       Off
    ProxyPreserveHost   On
 
    <Proxy *>
        Order deny,allow
        Allow from all
    </Proxy>
   
    ProxyPass       /jira   http://wikitest64:8090/jira
    ProxyPassReverse    /jira   http://wikitest64:8090/jira     
   

   
    ProxyPass       /confluence   http://wikitest64:8080/confluence
    ProxyPassReverse    /confluence   http://wikitest64:8080/confluence
   
     
         
</VirtualHost>
herryeh
 
Posts: 2
Joined: 12. November 2014 14:45
Operating System: Windows 2008 Server r2

Re: Autom. Weiterlg http –>https nach 8080 läuft und 8090 ni

Postby Nobbie » 14. November 2014 12:08

Sorry, das ist so wild konfiguriert, erkläre doch bitte mal ausführlich "in Prosa", was Du genau machen willst. Wenn ich die Konfigurationsdateien lese, dann steht da ungefähr drin, dass Du einen einzigen Rechner besitzt, der heißt wikipedia64 und da läuft u.a. Xampp und da ist u.a. Jira und Confluence installiert (kenne ich beides nicht). Bis dahin ist es einfach.

Aber jetzt wird es absolut wild: Du definierst zwei VirtualHosts (der Sinn von virtuellen Hosts besteht primär darin, verschiedene Namen für die gleiche IP zu benutzen), aber diese virtuellen Host bekommen alle den gleichen Namen wikitest64 (vollkommen widersprüchlich zum Sinn von VirtualHosts). Zusätzlich läßt Du diese VirtualHosts einmal auf Port 80 laufen (das ist http Standard und in Ordnung), den anderen aber auf Port 90 (wieso das??) wodurch man gezwungen ist, den Port in der URL nachher auch anzugeben.

Jira und Confluence laufen ihrerseits auf Port 8080 und 8090 (warum auch immer), in Xampp werden die VirtualHosts benutzt, um via ReverseProxy auf die beiden Applikationen zuzugreifen, was aber total sinnfrei ist, weil man ja auch direkt zugreifen kann (einfach via http://wikitest64:8080). Das verstehe ich überhaupt nicht.

Bis hier verstehe ich weder Sinn noch Zweck dessen, was da gemacht wird. Last not least stehen für https noch zwei ProxyPass Direktiven im VirtualHost für Port 443, das sieht so aus, als wenn da das gewünschte auch passiert, dass http auf https und die jeweilige Applikation stattfindet. Die anderen VirtualHosts und die dort vereinbarten ReverseProxys sind nicht zu verstehen.

Last not least sind Jira und Confluence relativ teure Produkte, die sicher nicht von Privatkunden betrieben werden. Haben die keinen Support, oder wofür bezahlt man da?
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests