Webseite zeigt bei Zugriff per https nur Directory Browsing

Alles, was den Apache betrifft, kann hier besprochen werden.

Webseite zeigt bei Zugriff per https nur Directory Browsing

Postby Cator Canulis » 09. November 2014 12:50

Hallo allerseits,

ich betreibe einen Apache 2.22.2 Server auf einem Raspberry Pi. SSL habe ich entsprechend dieser Anleitung http://wiki.ubuntuusers.de/Apache/SSL?highlight=apache%20ssl eingeschaltet.

Alle Seiten bis auf jene eines JWChat-Webclients (https://jwchat.org/) funktionieren normal. Besagte Seite verhält sich nur bei Aufruf über http normal, zeigt aber bei Aufruf über https nur den Inhalt des entsprechenden Serververzeichnisses. JWChat nutzt Javascripts und liefert unterschiedliche index.html.* Dateien, je nach Sprache des Servers. Benenne ich z.B. index.html.de zu index.html um, wird die Seite geladen. Einie Steuerelemente bleiben aber ausgegraut und das Seitenstil ist teilweise zerschossen.

Zusatzinfo: Lädt man sich JWChat herunter und klickt auf die entsprechende index.html.* Datei, so erhält man denselben Effekt.

Meine erste Frage: Ist es möglich, dass dieses Problem am Apacheserver liegt?

Meine zweite Frage: Falls ja, was muss ich tun, um es zu lösen?

Viele Grüße und besten Dank im Voraus,
Markus
Cator Canulis
 
Posts: 2
Joined: 09. November 2014 12:35
Operating System: Linux Mint 17

Re: Webseite zeigt bei Zugriff per https nur Directory Brows

Postby Nobbie » 09. November 2014 15:40

Cator Canulis wrote:Meine erste Frage: Ist es möglich, dass dieses Problem am Apacheserver liegt?


Jain - es "liegt" nicht an Apache, sondern daran, dass entweder der Chat schlecht dokumentiert ist oder Du die Doku nicht gelesen hast. Man kann mit Apache ein entsprechendes Verhalten erzwingen, Hauptstichwort lautet "MultiViews" (das ist eine Option für den DocumentRoot beispielsweise) und das ganze Thema läuft unter "mod_negotiation":

http://httpd.apache.org/docs/2.2/mod/mo ... ation.html
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Webseite zeigt bei Zugriff per https nur Directory Brows

Postby Cator Canulis » 09. November 2014 19:29

Danke für den Tipp. Eine .htaccess-Datei mit folgendem Inhalt war die Lösung:
Code: Select all
# Einstellungen für alternative Inhalte
Options MultiViews FollowSymLinks IncludesNoExec
AddOutputFilter INCLUDES .shtml .shtm
Order allow,deny
Allow from all
Cator Canulis
 
Posts: 2
Joined: 09. November 2014 12:35
Operating System: Linux Mint 17


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests