.htaccess nur bei SSL

Alles, was den Apache betrifft, kann hier besprochen werden.

.htaccess nur bei SSL

Postby themrdomi » 15. October 2014 20:03

Hallo,
ich wollte heute meinen Apache Webserver auf meinem Raspberry per SSL verschlüsseln, doch nun gibt es ein Problem:
Ich habe eine .htaccess Datei, die mich normalerweise nach einem Benutzernamen und Passwort fragt.
Nun fragt sie mich jedoch nur, wenn ich versuche mich per https:// einzuloggen.
Per http:// wird mir meine index.html einfach normal angezeigt.
Außerdem habe ich versucht, eine weiterleitung auf https:// einzurichten, welche jedoch nicht geklappt hat. (Er ruft einfach die normale Seite auf bei http)

Hier ist meine .htaccess Datei:

Code: Select all
AuthType Basic
AuthName "Protected Area"
AuthUserFile /var/www/.htpasswd
Require valid-user


Diesen Code habe ich zur Weiterleitung verwendet:

Code: Select all
RewriteBase /
RewriteEngine on
RewriteCond %{SERVER_PORT} !443
RewriteRule (.*) https://%{HTTP_HOST}$1 [R=301,L]


Ich freue mich, wenn mir jemand helfen kann :)#

Gruß,
Dominik
themrdomi
 
Posts: 2
Joined: 15. October 2014 19:16
Operating System: Windows

Re: .htaccess nur bei SSL

Postby themrdomi » 15. October 2014 20:29

Ich habe den Fehler gefunden:
Ich musste in der Datei /etc/apache2/sites-enabled/000-default den Wert AllowOverride None zu AllowOverride All ändern.
Eine Frage habe ich jetzt jedoch noch: Ich werde erfolgreich zur https Seite weitergeleitet, jedoch fordert mich der Browser logischerweise auf, zweimal das Passwort einzugeben, einmal für http://XXX.XXX.XXX.XX
und einmal für https://XXX.XXX.XXX.XX
Kann man irgendwo einstellen, dass er es automatisch übernimmt?

Lg

Edit: Folgender Code ermöglicht es einem, das Passwort nur einmal eingeben zu müssen:
Code: Select all
   
SSLOptions +StrictRequire
SSLRequireSSL
SSLRequire %{HTTP_HOST} eq "www.xxxxx.de"
ErrorDocument 403 https://www.xxxxxx.de
themrdomi
 
Posts: 2
Joined: 15. October 2014 19:16
Operating System: Windows


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests