"corrupted content" error, kein Zugriff auf SSL key

Alles, was den Apache betrifft, kann hier besprochen werden.

"corrupted content" error, kein Zugriff auf SSL key

Postby bennypr0fane » 28. September 2014 18:37

Hallo,
Ich meine https-Website ist nicht erreichbar, ich bekomme folgende Fehlermeldung:
"Fehler: Beschädigte Inhalte
Die Seite, die Sie anzusehen versuchen, kann nicht angezeigt werden, da ein Fehler in der Datenübertragung festgestellt wurde."
In anderen Browsern wird auch einfach die Warnung angezeigt, dass der Seite nicht vertraut wird (was normal ist, da ich ein selbstsigniertes Zertifikat verwende), aber die Option, die Warnung zu übergehen/Ausnahme zu machen, funktioniert nicht.
Apache sagt mir dazu:
Code: Select all
~$ apachectl -S
AH00526: Syntax error on line 22 of /etc/apache2/sites-enabled/000-default.conf:
SSLCertificateKeyFile: file '/etc/ssl/private/owncloud.key' does not exist or is empty
Action '-S' failed.

Ich habe aber sichergestellt, dass Die Datei da ist und auch den Schlüssel enthält. Anscheinend hat Apache keine Zugriff/keine Berechtigung.
Hier sind die Berechtigungen [EDIT]:
Code: Select all
~$ sudo ls -l /etc/ssl/private/owncloud.key
-rw-r--r-- 1 root ben 1704 Sep 28 04:01 /etc/ssl/private/owncloud.key

ben ist mein normaler User.
Eine Vermutung im #http IRC Channel war, dass Apparmor etwas verbockt hat, aber ich habe keine Ahnung, wie ich das überprüfen bzw in Ordnung bringen könnte.
Ich bin kompletter Anfänger und Autodidakt, und das ist der erste Server, den ich selber aufsetze. Bin froh über gute Leseempfehlungen - aber je genauer eingegrenzt das Lesethema, desto besser ;-)

I can't reach my website, I get a "corrupted content" error message in the browser.
Looking into apache (version 2.4.7), I get
Code: Select all
~$ apachectl -S
AH00526: Syntax error on line 22 of /etc/apache2/sites-enabled/000-default.conf:
SSLCertificateKeyFile: file '/etc/ssl/private/owncloud.key' does not exist or is empty
Action '-S' failed.

However, I double checked that the file is in the appropriate location and does contain the key, so maybe apache has no permission. afaik, it doesn't run as root all the time - or only for a short time?
permissions for the key file are as follows [EDIT]:
Code: Select all
~$ sudo ls -l /etc/ssl/private/owncloud.key
-rw-r--r-- 1 root ben 1704 Sep 28 04:01 /etc/ssl/private/owncloud.key

, where ben is my normal user.
It was suggested to me on the httpd IRC channel that maybe apparmor was doing something wrong, but I don't know how to investigate that.
Any hints?
I actually don't have XAMPP installed as a Package.
Apache version is 2.4.7.
bennypr0fane
 
Posts: 1
Joined: 28. September 2014 17:38
Location: Austria
Operating System: Ubuntu 14.04

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests