Apache apachectl-k start error while loading shared librarie

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache apachectl-k start error while loading shared librarie

Postby dmean » 04. September 2014 22:58

Running into an issue with an apache/php installation.

Redhat 6.5 Apache 2.4 PHP 5.6

Installed apache in a non-standard installation(did not use yum install httpd). I did so by: -placing the apache zip onto the server -./configure --prefix=/usr/dir/.... make make install

After this apache started and I was able to hit it on a browser. I then stopped apache to install php.

installed PHP and its dependencies which included: libxml2 python

then I ran ./configure --prefix=/usr/dir/util/php --with-libxml-dir=/usr/dir/uti/util/libxml2/ --with-apxs2=/usr/dir/uti/apache/bin/apxs

then I configured apache httpd.conf with LoadModule php5_module modules/libphp5.so

When I attempted to start apache I received the following error message

/httpd: error while loading shared libraries: libpcre.so.1: cannot open shared object file: No such file or directory
dmean
 
Posts: 1
Joined: 04. September 2014 22:53
Operating System: redhat 6.5

Re: Apache apachectl-k start error while loading shared libr

Postby Nobbie » 05. September 2014 11:13

libpcre.o is the library for regular expressions. Maybe you included this in php.ini, but you did not install it?!

Anyway, this question is totally wrong here, first of all this is a GERMAN board, next it is not an Apache issue (it looks more like a very personal linux problem, as you did not install with standard installation procedure), you may have more success in a RedHat board.
Nobbie
 
Posts: 8766
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests