User-Verzeichnis wird nicht gefunden

Alles, was den Apache betrifft, kann hier besprochen werden.

User-Verzeichnis wird nicht gefunden

Postby Holley » 14. August 2014 15:20

Hello,

ich bin neu bei Mac und neu bei Apache - allerdings seit Jahren Webentwicklerin unter Windows. Also ein bisschen was bringe ich mit.
Ich habe OS X 10.9.4 und Apache 2.2.26.
Der Apache war ja vorinstalliert und läuft wie auch der Aufruf im Browser zeigt.
Ich habe das php5-Modul in der httpd.conf aktiviert.

Gemäß einer Anleitung habe ich in meinem User-Verzeichnis ein Verzeichnis Sites erzeugt und dort eine phpinfo abgelegt.
Beim Aufruf im Browser (http://localhost/%Username%/phpinfo.php mit und ohne Tilde vor username - da steige ich auch noch nicht so ganz durch) erhalte ich die Nachricht "The requested URL /%Username%/phpinfo.php was not found on this server."
Sie ist aber definitiv vorhanden und mit dem Terminal zu sehen.

Ein Verzeichnis htdocs, auf das andere Anleitungen verweisen, finde ich gar nicht.
Weder unter /Library/WebServer/Documents noch unter /Users/UserName/Sites

Ich weiß, mir fehlt da einiges an Grundlagen. Aber an dieser Stelle ist bestimmt nur ein ganz blöder Denkfehler, bei dem mir vielleicht jemand ganz leicht auf die Sprünge helfen kann?

Wäre sehr dankbar...
Holley
 
Posts: 2
Joined: 14. August 2014 12:10
Operating System: Mac OS X 10.9.4

Re: User-Verzeichnis wird nicht gefunden

Postby Nobbie » 14. August 2014 17:14

Holley wrote:Gemäß einer Anleitung


Und da sind wir schon beim Knackpunkt: welche Anleitung? Da steht och sicherlich noch viel mehr, wie und wo was das ganze soll und was das alles bedeutet?!

Holley wrote:Beim Aufruf im Browser (http://localhost/%Username%/phpinfo.php mit und ohne Tilde vor username - da steige ich auch noch nicht so ganz durch) erhalte ich die Nachricht "The requested URL /%Username%/phpinfo.php was not found on this server.


Das funktioniert nur mit Tilde davor.

Und das ganze ist eine Erweiterung von Apache (ein sog. "Modul"), mit dem das realisiert wird dieses Modul nennt sich "mod_userdir". D.h., das ganze funktioniert auch nur dann, wenn dieses Modul von Apache geladen wird, das steht in der httpd.conf, ob und welches Modul geladen wird. Und wie das ganze syntaktisch und von der Logik her funktioniert, steht zumindest schon einmal in der Original Doku dazu: http://httpd.apache.org/docs/2.2/mod/mod_userdir.html

Aber es gibt darüber hinaus sicherlich auch jede Menge Tutorials und Beispiele, welche Einstellungen Du vornehmen kannst und sollst, damit es so wie gewünscht funktioniert. Ohne dieses Modul würde Apache einfach einen Ordner "~username" im DocumentRoot suchen und genau das willst Du natürlich nicht.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: User-Verzeichnis wird nicht gefunden

Postby Holley » 14. August 2014 20:08

l
Nobbie wrote:Und da sind wir schon beim Knackpunkt: welche Anleitung? Da steht och sicherlich noch viel mehr, wie und wo was das ganze soll und was das alles bedeutet?!

Ich verstehe die Frage nicht.

Nobbie wrote:Und das ganze ist eine Erweiterung von Apache (ein sog. "Modul"), mit dem das realisiert wird dieses Modul nennt sich "mod_userdir". D.h., das ganze funktioniert auch nur dann, wenn dieses Modul von Apache geladen wird

Das Modul IST geladen.
Es funktioniert nicht. Weder mit noch ohne Tilde davor. Wie ich schon schrieb.

Nobbie wrote:Aber es gibt darüber hinaus sicherlich auch jede Menge Tutorials und Beispiele, welche Einstellungen Du vornehmen kannst und sollst, damit es so wie gewünscht funktioniert. Ohne dieses Modul würde Apache einfach einen Ordner "~username" im DocumentRoot suchen und genau das willst Du natürlich nicht.


Ja, super Hinweis. Habe ich gelesen. Mindestens schon vier Stück. Jeder beschreibt einen anderen Weg. Und ich habe es nicht hinbekommen. Deshalb bin ich jetzt hier. In diesem Forum. Was ist daran falsch?
Kapier ich nicht ...
Holley
 
Posts: 2
Joined: 14. August 2014 12:10
Operating System: Mac OS X 10.9.4

Re: User-Verzeichnis wird nicht gefunden

Postby Nobbie » 14. August 2014 22:08

Holley wrote:Ich verstehe die Frage nicht.


Was ist daran nicht zu verstehen? Du hast eine "Anleitung" gelesen, aber was wurde dort "angeleitet" und warum? Das einzige, was Du aus dieser "Anleitung" zitierst, ist der Umstand, dass Du "habe ich in meinem User-Verzeichnis ein Verzeichnis Sites erzeugt und dort eine phpinfo abgelegt." Wieso hast Du das getan?

----

Holley wrote:Kapier ich nicht ...


Dann eben nicht. Kann ich nicht ändern. Auf Deinen pampigen Tonfall habe ich keinen Bock. Bekommst Du halt nicht hin, fertig.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests