<Directory /> and AH01630: client denied by server configura

Alles, was den Apache betrifft, kann hier besprochen werden.

<Directory /> and AH01630: client denied by server configura

Postby matimont » 22. May 2014 03:17

Hi,

I've got rid of the below lines in my apache configuration file in order to prevent an error I was getting.
I know for sure this is not a best practice so how can I avoid this issue?

here's what I was getting in the logs when I had the <Directory /> stuff in my config..
AH01630: client denied by server configuration: /home/mywebsite/public_html/index.php

Lines I removed:

<Directory />
Options FollowSymLinks
AllowOverride None
Require all denied
</Directory>

<Directory /usr/share>
AllowOverride None
Require all granted
</Directory>

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride None
Require all granted
</Directory>
matimont
 
Posts: 2
Joined: 22. May 2014 03:09
Operating System: Ubuntu Server 14.04

Re: <Directory /> and AH01630: client denied by server confi

Postby Nobbie » 22. May 2014 10:53

matimont wrote:I know for sure this is not a best practice so how can I avoid this issue?


a) Re-Insert the lines in your configuration

b) Add another <Directory ...> Block at the end, which grants access to your home directory:

<Directory /home/mywebsite>
AllowOverride All
Require all granted
</Directory>

c) Restart Apache

d) And begin to read the Apache Documentation, at least about "Require" and "Directory"

e) ... and write in German next time or proceed to the English part (in the bottom), as this is the German board.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: <Directory /> and AH01630: client denied by server confi

Postby matimont » 29. May 2014 20:01

Dankeschön, Danke sehr
matimont
 
Posts: 2
Joined: 22. May 2014 03:09
Operating System: Ubuntu Server 14.04


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests