Ins Internet mit dir! - Nö

Alles, was den Apache betrifft, kann hier besprochen werden.

Ins Internet mit dir! - Nö

Postby marabunta » 19. May 2014 21:17

Hi,

ich habe XAMPP 3.2.1 und Apache läuft auch. Der Router ist korrekt eingestellt und ich bekomme Zugriff verweigert wenn ich aus dem Internet darauf zugreifen möchte. Soweit Standard und alles ok.
Laut Anleitungen muss ich nur meinen PC mit Requireany o.ä. mit eintragen damit es funktioniert. Klappt nur nicht.

Code: Select all
[Mon May 19 21:49:11.316023 2014] [authz_core:error] [pid 5708:tid 1696] [client 192.168.2.1:5483] AH01630: client denied by server configuration: E:/XAMPP/htdocs/xampp/

[Mon May 19 22:00:16.111047 2014] [mpm_winnt:notice] [pid 6060:tid 264] AH00455: Apache/2.4.9 (Win32) OpenSSL/1.0.1g PHP/5.5.11 configured -- resuming normal operations
[Mon May 19 22:00:16.111047 2014] [mpm_winnt:notice] [pid 6060:tid 264] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:13:13
[Mon May 19 22:00:16.111047 2014] [core:notice] [pid 6060:tid 264] AH00094: Command line: 'e:\\xampp\\apache\\bin\\httpd.exe -d E:/XAMPP/apache'
[Mon May 19 22:00:16.114047 2014] [mpm_winnt:notice] [pid 6060:tid 264] AH00418: Parent: Created child process 6236
[Mon May 19 22:00:16.752084 2014] [ssl:warn] [pid 6236:tid 276] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon May 19 22:00:16.967096 2014] [ssl:warn] [pid 6236:tid 276] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon May 19 22:00:16.999098 2014] [mpm_winnt:notice] [pid 6236:tid 276] AH00354: Child: Starting 150 worker threads.



Code: Select all
[19-May-2014 21:29:42 Europe/Berlin] PHP Warning:  file_get_contents(lang.tmp): failed to open stream: No such file or directory in E:\XAMPP\htdocs\xampp\index.php on line 2

[19-May-2014 21:31:57 Europe/Berlin] PHP Notice:  Undefined index: HTTP_HOST in E:\XAMPP\htdocs\index.php on line 7

[19-May-2014 21:35:04 Europe/Berlin] PHP Notice:  Undefined index: HTTP_HOST in E:\XAMPP\htdocs\index.php on line 7

[19-May-2014 21:39:13 Europe/Berlin] PHP Notice:  Undefined index: HTTP_HOST in E:\XAMPP\htdocs\index.php on line 7

[19-May-2014 21:43:01 Europe/Berlin] PHP Notice:  Undefined index: HTTP_HOST in E:\XAMPP\htdocs\index.php on line 7

Code: Select all
#
# XAMPP settings
#

<IfModule env_module>
    SetEnv MIBDIRS "E:/XAMPP/php/extras/mibs"
    SetEnv MYSQL_HOME "\\xampp\\mysql\\bin"
    SetEnv OPENSSL_CONF "E:/XAMPP/apache/bin/openssl.cnf"
    SetEnv PHP_PEAR_SYSCONF_DIR "\\xampp\\php"
    SetEnv PHPRC "\\xampp\\php"
    SetEnv TMP "\\xampp\\tmp"
</IfModule>

#
# PHP-Module setup
#
LoadFile "E:/XAMPP/php/php5ts.dll"
LoadFile "E:/XAMPP/php/libpq.dll"
LoadModule php5_module "E:/XAMPP/php/php5apache2_4.dll"

<FilesMatch "\.php$">
    SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
    SetHandler application/x-httpd-php-source
</FilesMatch>

#
# PHP-CGI setup
#
#<FilesMatch "\.php$">
#    SetHandler application/x-httpd-php-cgi
#</FilesMatch>
#<IfModule actions_module>
#    Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#</IfModule>


<IfModule php5_module>
    PHPINIDir "E:/XAMPP/php"
</IfModule>

<IfModule mime_module>
    AddType text/html .php .phps
</IfModule>

ScriptAlias /php-cgi/ "E:/XAMPP/php/"
<Directory "E:/XAMPP/php">
    AllowOverride None
    Options None
    Require all denied
    <Files "php-cgi.exe">
          Require all granted
    </Files>
</Directory>

<Directory "E:/XAMPP/cgi-bin">
    <FilesMatch "\.php$">
        SetHandler cgi-script
    </FilesMatch>
    <FilesMatch "\.phps$">
        SetHandler None
    </FilesMatch>
</Directory>

<Directory "E:/XAMPP/htdocs/xampp">
    <IfModule php5_module>
       <Files "status.php">
          php_admin_flag safe_mode off
       </Files>
    </IfModule>
    AllowOverride AuthConfig
</Directory>

<IfModule alias_module>
    Alias /security "E:/XAMPP/security/htdocs/"
    <Directory "E:/XAMPP/security/htdocs">
        <IfModule php5_module>
          <Files "xamppsecurity.php">
             php_admin_flag safe_mode off
          </Files>
        </IfModule>
        AllowOverride AuthConfig
        Require all granted
   </Directory>

    Alias /licenses "E:/XAMPP/licenses/"
    <Directory "E:/XAMPP/licenses">
        Options +Indexes
        <IfModule autoindex_color_module>
            DirectoryIndexTextColor  "#000000"
            DirectoryIndexBGColor "#f8e8a0"
            DirectoryIndexLinkColor "#bb3902"
            DirectoryIndexVLinkColor "#bb3902"
            DirectoryIndexALinkColor "#bb3902"
        </IfModule>
        Require all granted
   </Directory>

    Alias /phpmyadmin "E:/XAMPP/phpMyAdmin/"
    <Directory "E:/XAMPP/phpMyAdmin">
        AllowOverride AuthConfig
        Require all granted
    </Directory>

    Alias /webalizer "E:/XAMPP/webalizer/"
    <Directory "E:/XAMPP/webalizer">
        <IfModule php5_module>
          <Files "webalizer.php">
             php_admin_flag safe_mode off
          </Files>
        </IfModule>
        AllowOverride AuthConfig
        Require all granted
    </Directory>
</IfModule>

#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-

status|server-info))">
<RequireAll>
   Require local
</RequireAll>
   
   ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>


Ich habe es ganz unten bei New XAMPP security concept geändert, ohne Erfolg.
Wo muss ich jetzt was eintragen, damit ich aus dem Internet überall drauf komme ausser auf die Admin Seite die Lokal bleiben soll?

Danke.
marabunta
 
Posts: 2
Joined: 19. May 2014 21:09
Operating System: w

Re: Ins Internet mit dir! - Nö

Postby Nobbie » 19. May 2014 22:07

marabunta wrote:Wo muss ich jetzt was eintragen, damit ich aus dem Internet überall drauf komme ausser auf die Admin Seite die Lokal bleiben soll?


Alles, was Du schon geändert hast, wieder rückgängig machen, denn das ist die Auslieferungseinstellung von Xampp. Unabhängig davon wird Xampp nur als Entwicklungsumgebung angeboten, für den Einsatz im Internet ist es nicht konzipiert (auch wenn die Auslieferung wenigstens ein paar Basisvorkehrungen trifft).
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Ins Internet mit dir! - Nö

Postby marabunta » 20. May 2014 16:47

und was soll ich benutzen um eine seite vom meinem rechner aus zu hosten? es ist jeweils nur kurz <10min tatsächlich im netz und wird wieder abgeschaltet. evtl. wird es auf einer vm gehostet.
ich brauch einfach nur irgendwas funktionierendes...
marabunta
 
Posts: 2
Joined: 19. May 2014 21:09
Operating System: w

Re: Ins Internet mit dir! - Nö

Postby Nobbie » 20. May 2014 19:15

marabunta wrote:und was soll ich benutzen um eine seite vom meinem rechner aus zu hosten?


Apache, PHP usw. - die gibt es auch "so" zum Herunterladen. Nur Xampp ist mega unsicher (das ist keine 5 minuten Online, da ist Dein Rechner gehackt), weil es mit Absicht so offen gestaltet wurde, damit Entwickler zuhause damit arbeiten können.

Oder irgendwelche Linux Distributionen mit vorinstallierten Umgebungen usw.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 7 guests