Mehrere PHP-Versionen unter Plesk 11.5, Extension-Problem!

Alles, was den Apache betrifft, kann hier besprochen werden.

Mehrere PHP-Versionen unter Plesk 11.5, Extension-Problem!

Postby Mucer85 » 18. September 2013 13:28

Ich habe CentOS 6.4 mit Plesk 11.5 und Apache laufen.
Bei Plesk 11.5 ist PHP 5.3.3 vorinstalliert und die Version ist auch Serverstandard.
Dazu hab ich jetzt PHP 5.5.3 in den Ordner /usr/local/php-5.5.3 installiert und bei Plesk angemeldet.
Funktioniert auch wunderbar! PHP 5.3 und PHP 5.5 laufen parallel.

Mein Problem:
Meine installierten Erweiterungen (mod's) werden nur bei der Vorinstallierten PHP 5.3.3 Version geladen, also Module wie: ioncubeload, clamav, suhosin, mcrypt usw...
Bei der manuell installierten Version 5.5.3 wird rein gar nichts geladen, auch wenn ich sie über über die PHP.ini, bzw. z.B. /etc/php.d/mcrypt.ini registriere.
Bsp.: extension=mcrypt.so
Ich kenne die genaue Architektur vom Apache nicht... Deshalb eine Frage:
Muss ich Module "speziell" für die PHP 5.5.3 registrieren/verknüpfen oder diese nochmal extra für die PHP-Version installieren, was ich nicht glaube.
Vielleicht kann mir jemand weiterhelfen?
Mucer85
 
Posts: 3
Joined: 18. September 2013 12:57
Operating System: CentOS 6.4

Re: Mehrere PHP-Versionen unter Plesk 11.5, Extension-Proble

Postby Nobbie » 18. September 2013 16:15

Mucer85 wrote:Muss ich Module "speziell" für die PHP 5.5.3 registrieren/verknüpfen oder diese nochmal extra für die PHP-Version installieren, was ich nicht glaube.


Ich glaube das aber schon. Was steht denn im Error Log?
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Mehrere PHP-Versionen unter Plesk 11.5, Extension-Proble

Postby Mucer85 » 18. September 2013 17:20

Error Log... hätte ich selber darauf kommen können. Aber Dankeschön :)

Kommen diese Warnungen:
PHP Warning: PHP Startup: xsl: Unable to initialize module
Module compiled with module API=20090626
PHP compiled with module API=20121212

Das heißt, dass die Module für PHP 5.3.3 zu 5.5.3 nicht kompatibel sind...
Also, alle jeweils 2mal installieren.
Mucer85
 
Posts: 3
Joined: 18. September 2013 12:57
Operating System: CentOS 6.4

Re: Mehrere PHP-Versionen unter Plesk 11.5, Extension-Proble

Postby Nobbie » 18. September 2013 17:45

Mucer85 wrote:Module compiled with module API=20090626
PHP compiled with module API=20121212


Siehst Du - genau was ich vermutet hatte. Aber statt viele Worte einfach auf den Error Log verweisen - ist für alle einfacher.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Mehrere PHP-Versionen unter Plesk 11.5, Extension-Proble

Postby Mucer85 » 18. September 2013 21:57

jedenfall vielen Dank :) Bin neu hier und war echt am verzweifeln...
Mucer85
 
Posts: 3
Joined: 18. September 2013 12:57
Operating System: CentOS 6.4


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests