mod_rewrite

Alles, was den Apache betrifft, kann hier besprochen werden.

mod_rewrite

Postby alex_badnauheim » 24. July 2004 22:46

hallöle.

xampp in der heutigen version und ich bekomme mod rewrite NICHT ans arbeiten! mod_rewrite ist unkommentiert# und mit phpinfo sichtbar.

meine .htaccess sieht wie folgt aus:

RewriteEngine On
Options FollowSymLinks
RewriteBase /
RewriteRule ^produkt-([0-9].*)\.html$ index.php?c_id=$1

ebenso versucht das " ^ " zeichen wegzulassen und den platzhalter
für die variable [0-9] nur in der stern version ... alles in allem viele versuche - deshalb nun dieses posting.

also so wie hier:
RewriteRule ^produkt-(.*)\.html$ index.php?c_id=$1


in der apache config habe ich das hier angelegt:

Alias /zr-page "c:/apachefriends/xampp/htdocs/zr-page/"

<Directory "c:/apachefriends/xampp/htdocs/zr-page/">
Order allow,deny
AllowOverride All
Allow from all
</Directory>


ich bekomme es absolut nicht ans laufen !!!

ach so' die verweise sehen so aus....

index.php?c_id=4711&hl_1=headline1&hl_2=headline2

ich wär ja schon froh wenn ich wenigstens meine seiten
nach produkt-4711.html konvertieren könnte - oder mal dieses modul
ans laufen bekäme....

also, evtl . habt ihr eine möglichkeit für mich

vielen lieben dank
alex
alex_badnauheim
 
Posts: 1
Joined: 24. July 2004 22:28

Postby n.d. parker » 28. July 2004 23:54

Moin,

wird die .htaccess-Datei überhaupt eingelesen?
(wenn du Müll reinschreibst, und er sich nicht beschwert, dann nicht).

nd
n.d. parker
 
Posts: 18
Joined: 10. February 2004 23:53

Postby TTP » 30. July 2004 12:34

ich hab das gleiche prob, selbst auf meinem webspace is das so =((

hier die phpinfo: http://www.ng-c.de/info.php
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg

Postby Wiedmann » 30. July 2004 13:22

ich hab das gleiche prob,

Und was für eines?

Und zu wissen was genau passiert wenn du rewrite einsetzt und wie...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby TTP » 01. August 2004 10:19

ich hab das gefühl, die .htaccess werden gar nicht beachtet, nur die die mein confixx erstellt funktionieren irgendwie. Aber das ist ja auch nicht mod_rewrite sondern nur der Zugansschutz. Was mach ich falsch?
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests