cgi Probleme

Alles, was den Apache betrifft, kann hier besprochen werden.

cgi Probleme

Postby Semml » 03. July 2004 16:26

Hallo Leute!

Hab da n Problem mit meinem Apache!
Bin n Neuling was Scripte angeht!
Ich Installierte Apache2 und ActivePerl unter WinXP!
Soweit so gut, alles hat gefuntzt.
Kann auch über localhost auf den Server schauen!
Nun wollt ich mich an die cgi machen!
Hab dann die httpd.conf konfiguriert!
Unter anderem auch:

ScriptAlias /cgi-bin/ "C:/Programme/Apache Group/Apache2/cgi-bin/"

#
# "C:/Programme/Apache Group/Apache2/htdocs/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "C:/Programme/Apache Group/Apache2/htdocs/cgi-bin">
AllowOverride all
AuthType None
Order Deny,Allow
Deny From None
Allow From All

So, hab dann noch n Chat in die cgi-bin rein, und alles was dazugehört!
Wollte dann über localhost den Chat installieren, doch ich komm net mal in den Ordner cgi-bin rein:

Forbidden
You don't have permission to access /cgi-bin/ on this server.

Haballes was in meiner Macht stand probiert, hat aber wahrscheinlich nicht gereicht!
Ich hoff mir kann son Freak helfen!
Danke schon mal!
Simon
Semml
 
Posts: 1
Joined: 03. July 2004 15:39

Postby daxim » 03. July 2004 19:36

Im <Directory>-Block fehlt noch ein
Code: Select all
Options ExecCGI
daxim
 
Posts: 53
Joined: 04. June 2004 20:45

Re: cgi Probleme

Postby Wiedmann » 03. July 2004 19:57

doch ich komm net mal in den Ordner cgi-bin rein:


Wie hast du denn versucht in den Ordner "reinzukommen"?
Du solltest da schon den Script direkt aufrufen:
"http://localhost/cgi-bin/forum.pl"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests