was is falsch? .htaccess

Alles, was den Apache betrifft, kann hier besprochen werden.

was is falsch? .htaccess

Postby TTP » 22. June 2004 14:02

Hi, ich hab ne .htaccess angelegt

Code: Select all
RewriteEngine on
Options FollowSymLinks

RewriteBase /

RewriteRule newsletter.html newsletter.php


aber wenn ich jetzt meine url http://meinserver.de/newsletter.html öffne, zeigt der nix an, wieso? liegt es vieleicht daran, dass es eine Nameserveradresse ist?
Place
ohne Apachefriends wär ich in meiner Entwicklung weiter zurück ;)
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg

Postby Wiedmann » 22. June 2004 14:57

aber wenn ich jetzt meine url http://meinserver.de/newsletter.html öffne

Tut doch. Es kommt die Homepage von "jahresdomain.de".... SCNR

Evtl. so:
RewriteRule ^newsletter\.html$ newsletter.php
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby fawkes » 22. June 2004 15:57

*schmunzel* :wink:

Ich glaube www.meinserver.de
war nur ein Platzhalter, oder?

Gruß,
Henning
fawkes
 
Posts: 34
Joined: 13. June 2004 18:58

Postby TTP » 22. June 2004 18:07

JA EIGENTLICH SCHON *gg* is ne domain in meinen HOSTS nicht die echte... k, probiere deinen vorschlag mal aus Wiedmann
Place
ohne Apachefriends wär ich in meiner Entwicklung weiter zurück ;)
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg

Postby TTP » 22. June 2004 20:35

hab jetzt
Code: Select all
RewriteEngine on
Options FollowSymLinks
RewriteBase /
RewriteRule ^newsletter\.html$ newsletter.php


geht aber immernoch nicht -.-


Nachtrag: Aber das Rewrite-Enginemodul is entkommentiert, muss doch gehen....
Place
ohne Apachefriends wär ich in meiner Entwicklung weiter zurück ;)
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg

Postby TTP » 26. June 2004 19:02

hmm, ich brauch immernoch hilfe -.-
Place
ohne Apachefriends wär ich in meiner Entwicklung weiter zurück ;)
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg

Postby PF4 » 26. June 2004 19:08

Überprüfe mal per deny from all ob die .htaccess überhaupt gelesen wird.

AllowOverride All in der httpd.conf usw.
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby TTP » 27. June 2004 10:37

ähm spanisch?

was soll ich machen?
Place
ohne Apachefriends wär ich in meiner Entwicklung weiter zurück ;)
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg

Postby DJ DHG » 27. June 2004 23:04

TTP wrote:ähm spanisch?

was soll ich machen?



lesen?

http://httpd.apache.org/docs-2.0/mod/mo ... .html#deny

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby TTP » 28. June 2004 21:48

joa is aktiviert ^^ geht aber trotzdem irgendwie net... kp warum
Place
ohne Apachefriends wär ich in meiner Entwicklung weiter zurück ;)
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg

Postby TTP » 11. July 2004 14:30

*help me*
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests