Apache läuft, lässt sich aber nicht aufrufen

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache läuft, lässt sich aber nicht aufrufen

Postby chribo » 10. July 2013 12:15

Hallo zusammen,

vorab ein paar Infos:

OS: CentOS 6.4 (Linux)
Apache-Version: Apache/2.2.15 (CentOS)

die Überschrift klingt etwas komisch, da ich nicht direkt weiß wie ich das Problem beschreiben soll.

Heute hatte ich unter CentOS 6.4 einen Syslog-Server "installiert", also einen Ordner in das Verzeichnis vom Apache gelegt, also unter /var/www/html/.
Nachdem ich den Syslog-Server neu installieren musste, habe ich anstelle des Syslog Ordners (src) unter /var/www/html/src/, den kompletten Pfad ab /html/src/ gelöscht.

Wenn ich vorher die IP-Adresse wo der Apache lief aufgerufen habe, kam immer die Apache-Startseite - wenn ich jetzt die IP im Browser aufrufe steht dort 'Not Found'. Selbst wenn ich den html-Ordner wieder manuell erstelle und dort eine HTML-Datei reinlege, kann ich diese nicht aufrufen.

Kann mir jemand helfen? Eine Neuinstallation kommt nicht in Frage, da an den Apache auch noch OMD geknüpft ist und dieses auch deinstalliert werden müsste.

EDIT: Beispiel zu meinem Problem:

IP (Beispiel) 10.11.12.133
Datei: index.php

Demnach wäre ja die Adresse um index.php aufzurufen: 10.11.12.133/index.php

Dazu muss die Datei ja im Ordner /var/www/html/ liegen, richtig?

Der Syslog-Server lag unter /var/www/html/src/, die Adresse für'n Browser war die 10.11.12.133/src/index.php.


Grüße!
Christian
chribo
 
Posts: 3
Joined: 10. July 2013 12:02
Operating System: CentOS

Re: Apache läuft, lässt sich aber nicht aufrufen

Postby Nobbie » 10. July 2013 12:20

Der HTTP Error Code wäre auch wichtig (ich vermute 403).

Wahrscheinlich hat der manuell angelegte Ordner ./html nicht ausreichende Zugriffsrechte für den Benutzer, unter dem der Prozess httpd (Apache) ausgeführt wird. Meistens ist das wwwdata oder so. Findet man in der httdp.conf unter der Direkive "User = ....".

Möglicherwiese hieß der Ordner aber auch htdocs und nicht html, das steht aber auch in der httpd.conf und das ist die Direktive DocumentRoot.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Apache läuft, lässt sich aber nicht aufrufen

Postby chribo » 10. July 2013 12:27

Hi,

der User heißt "Apache" - habe auf den Ordner www + Unterordner die Berechtigungen "Für andere" auf Lesen und Schreiben gesetzt, das scheint wohl nicht das Problem gewesen zu sein.

Hier die Fehlermeldung die ausgegeben wird:

Not Found

The requested URL /test.html was not found on this server.

Die DocumentRoot ist "/var/www/html".
chribo
 
Posts: 3
Joined: 10. July 2013 12:02
Operating System: CentOS

Re: Apache läuft, lässt sich aber nicht aufrufen

Postby chribo » 10. July 2013 12:31

chribo wrote:Hi,

der User heißt "Apache" - habe auf den Ordner www + Unterordner die Berechtigungen "Für andere" auf Lesen und Schreiben gesetzt, das scheint wohl nicht das Problem gewesen zu sein.

Hier die Fehlermeldung die ausgegeben wird:

Not Found

The requested URL /test.html was not found on this server.

Die DocumentRoot ist "/var/www/html".



Habe die Kiste mal neugestartet und die httpd gechecked, da war DocumentRoot ausgerautet - die test.html funktioniert und wird problemlos angezeigt!

Trotzdem danke!
chribo
 
Posts: 3
Joined: 10. July 2013 12:02
Operating System: CentOS


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests