htaccess Problem (sehr nervig)

Alles, was den Apache betrifft, kann hier besprochen werden.

htaccess Problem (sehr nervig)

Postby Fischl » 12. June 2013 12:24

Hallo Leute.

Ich möchte (durch htaccess) bei der Eingabe einer "http://www.domain.de" Adresse auf eine "https://www.domain.de" umleiten, OHNE(!) nur den Port abzufragen. Er ignoriert allerdings http bei meinen Regeln:

RewriteCond %{HTTP_HOST} ^domain\.de$ [NC]
RewriteRule ^(.*)$ https://www.domain.de/$1 [R=301,L]

RewriteCond %{HTTP_HOST} ^www\.domain\.de$ [NC]
RewriteRule ^(.*)$ https://www.domain.de/$1 [R,L]


# RewriteCond %{SERVER_PORT} !^443$
# RewriteRule ^(.*)$ https://www.domain.de/$1 [R,L]

RewriteCond %{HTTP_HOST} ^\launch.domain.de$ [NC]
RewriteRule ^(.*)$ http://launch.domain.de/$1 [R,L]

Was dazu führt, dass er bei dieser Regel einen Umleitungsfehler bekommt, da für ihn ja die Cond immer wieder true ist. Er achtet also nicht drauf, ob man die "www.domain.de" von einer https eingibt, oder einer http. Ich hatte auch die http schon drin bei der Cond. Juckt ihn nicht. Er guckt nur nach dem "www". Kann ich sonst zwei Bedingungen kombinieren, sodass ich sage, wenn "www.domain.de" AND "Server Port ist nicht 443" (oder halt nur http und nicht https) DANN...? Dass sich diese Portregel nur auf diese spezielle Domaineingabe bezieht? Denn ich bekomme bei der allgemeinen Umleitung auf https (hier auskommentiert) keinen Zugriff auf meine Subdomain.

Die anderen Regeln funktionieren. Was mache ich falsch? Habe schon seit Stunden etliche Lösungen ausprobiert. Bin ratlos und total genervt.

:(
Fischl
 
Posts: 1
Joined: 12. June 2013 12:22
Operating System: Win 7

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests