Index.html

Alles, was den Apache betrifft, kann hier besprochen werden.

Postby NoFear » 25. May 2004 14:25

also er mag immer noch nicht.
ich poste mal den abschnitt directory, vielleicht übersehe ich ja nach 7 stunden am rechner auch einfach etwas.
ich habe alle index.html dateien in einen anderen ordner verschoben.
als fehlermeldung kommt:
Access forbidden!
You don´t have permission to access the requested directory.
There is either no index document or the directory is read-protected
Error 403

das verzeichniss htdocs hat den chmod 775
Code: Select all
<Directory>
Options +Indexes
AllowOverride None
Order allow,deny
Allow from all
</Directory>

vielleicht hilft das ja bei der problemlösung.
User avatar
NoFear
 
Posts: 7
Joined: 27. February 2004 13:02

Postby Wiedmann » 25. May 2004 15:01

NoFear wrote:
Code: Select all
<Directory>
Options +Indexes
AllowOverride None
Order allow,deny
Allow from all
</Directory>



Vergleich mal meinen Satz:
Wiedmann wrote:Innerhalb des <Directory> - Abschnittes der zu deinem htdocs-Verzeichnis gehört,...

Einfach so <Directory> reinschreiben tut also nicht, woher soll der Apache wissen welches Verzeichnis du meinst?
...gibt es eine Anweisung "Options".

"gibt" bedeutet meist, das schon etwas da ist...
Such also den schon vorhandenen <Directory>-Abschnitt für dein "htdocs" und pass den an.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby NoFear » 25. May 2004 15:21

das ist der schon vorhandene Directory teil meiner httpd.conf
ich habe hinter Options lediglich ein vorhandenes None durch +Indexes ersetzt.
oder hatte ich aus den vorherigen postings etwas fehlinterpretiert ?
User avatar
NoFear
 
Posts: 7
Joined: 27. February 2004 13:02

Postby Wiedmann » 25. May 2004 15:26

Der vorhandene Eintrag fängt betimmt so an:
<Directory "C:/xampp/htdocs">

oder ähnlich. Zumindest muß da ein Pfad stehen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby NoFear » 25. May 2004 15:31

da ich linuxuser bin werde ich nochmal nachschauen und poste dann das ergebniss.
danke für dir schon mal im vorraus ich hab dann wohl an einer völlig falschen stelle in meiner httpd.conf geschaut.
desweiteren ist bei mir auch nicht xampp sondern alle apache2 module gesondert installiert.
User avatar
NoFear
 
Posts: 7
Joined: 27. February 2004 13:02

Postby Wiedmann » 25. May 2004 15:37

Das macht keinen Unterschied, Linux oder Windows, xampp oder Apache pur. In jedem Fall gibt es einen Directory-Abschnitt der auf das htdocs verweisst.

Bei Linux könnte es dann z.B. folgendes o.ä. sein:
<Directory /usr/local/httpd/htdocs>

Vor dieser Zeile steht in der httpd.conf garantiert:
Code: Select all
#
# This should be changed to whatever you set DocumentRoot to.
#
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Previous

Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests