Index.html

Alles, was den Apache betrifft, kann hier besprochen werden.

Index.html

Postby Dj Andi » 04. May 2004 19:05

Hallo!

Hab da mal wieder ne Frage. :D

Wie bekomme ich das hin, wenn im Haupverzeichnis oder Unterverzeichniss keine index steht, die Fehlermeldung 404 kommt?

Gruß Andreas
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Postby Wiedmann » 04. May 2004 19:14

Options -Indexes

im Directory-Abschnitt der auf das Verzeichnis verrweisst (httpd.conf) oder in dem Verzeichnis in einer .htaccess
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dj Andi » 04. May 2004 19:25

Habe ich grade mal probiert, kommt aber aber nicht die Fehlermeldun 404 sondern 403
Forbidden
You don't have permission to access /spicons/ on this server.


wollte eigendglich das das kommt:
error 404: Datei nicht gefunden!

Das angegebene Dokument konnte auf diesem Server leider nicht gefunden werden.
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Postby Wiedmann » 04. May 2004 21:12

wollte eigendglich das das kommt:
error 404: Datei nicht gefunden!

Das angegebene Dokument konnte auf diesem Server leider nicht gefunden werden.


Dann mußt du mod_autoindex ganz deaktivieren (und sämtliche Direktiven die sich darauf beziehen, z.B. [+/-]Indexes, entfernen).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dj Andi » 05. May 2004 07:43

Wenn ich das deaktiviere lässt sich der Apache nicht mehr starten.
Wenn das irgend wie geht, möchte ich das so haben, das es sich nur auf die angelegten VHosts auswirkt.
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Postby Wiedmann » 05. May 2004 11:24

Hi Andi

Wenn ich das deaktiviere lässt sich der Apache nicht mehr starten.

Hätte das vielleicht nicht in Klammern schreiben dürfen ;-) :
... und sämtliche Direktiven die sich darauf beziehen, z.B. [+/-]Indexes, entfernen ...

kommt aber aber nicht die Fehlermeldun 404 sondern 403
...
Wenn das irgend wie geht, möchte ich das so haben, das es sich nur auf die angelegten VHosts auswirkt.

Da sieht es schlecht aus... Module kannst du nur global aktivieren (laden) oder halt nicht.
Und wenn das Modul geladen ist, wird entweder ein Index generiert (Options +Indexes) oder es kommt der Fehler 403 weil Indexes nicht erlaubt sind (Options -Indexes).
Option [+/-]Indexes kannst du allerdings schon in jeden VHOST getrennt einstellen. Halt mit den genannten Auswirkungen.

Ist zwar nicht ganz korrekt, weil nicht wirklich zutreffend, aber du könntest ja auch beim Fehler 403 auf das ErrorDocument von 404 verweisen. Dann siehst du aber nicht mehr, wenn du z.B. wegen einem "Deny from" abgewiesen wurdest.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dj Andi » 05. May 2004 22:00

schade....
aber wie machen die das bei GMX denn?
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

Postby Wiedmann » 05. May 2004 22:04

Dj Andi wrote:schade....
aber wie machen die das bei GMX denn?

Wie machen die was?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Dj Andi » 05. May 2004 22:38

Hatt sich schon erledigt GMX hatt das wohl geändert. Jetzt kommt bei dennen auch die 403 Meldung.
Seltsam, seltsam..... :?
Dj Andi
 
Posts: 58
Joined: 17. May 2003 16:44
Location: NRW

404 Mldg

Postby NickiGraus » 06. May 2004 07:11

Hi,

1) Die meisten Free-Hoster 'umgehen' das, indem sie in jeden Verzeichnis beim anlegen automatisch eine index.html erzeugen. Diese enthält nichts weiter als Redirect auf 404.

2) Dieses Lösung ist mir nur theoretisch bekannt! Du kannst eine Standartseite festlegen, welche immer angezeigt werden soll, wenn die gesuchte Datei nicht vorhanden ist. Es wird nie der Fehler 404 bedient. Viele 'Ab 18' Free Hoster nutzen dieses. Doch wenn du in das Verzeichnis per FTP schaust, ist es leer.
Es ist ein Beweis der Bildung, die größten Dinge auf die einfachste Art zu sagen.

RW Emerson

Image
User avatar
NickiGraus
 
Posts: 40
Joined: 05. May 2004 12:49
Location: Irland

Postby NoFear » 25. May 2004 08:53

moin,
ich hätte da auch mal eine Frage.
und zwar möchte ich wenn keine index vorhanden ist das alle dateien und ordner im htdocs verzeichniss angezeigt werden.
wie kann ich das unter apache2 realisieren ?
User avatar
NoFear
 
Posts: 7
Joined: 27. February 2004 13:02

Postby Wiedmann » 25. May 2004 10:16

Macht der das nicht von sich aus? Ich denk das ist das Standardverhalten vom Apache nach der Installation.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby NoFear » 25. May 2004 12:24

bei mir ist das nicht der fall, wenn keine index.html vorhanden ist zeigt er zugriff verweigert an.
User avatar
NoFear
 
Posts: 7
Joined: 27. February 2004 13:02

Postby mckinley » 25. May 2004 12:52

das kannst du einstellen in der httpd.conf

in dem <directory ></directory> abschnitt
User avatar
mckinley
 
Posts: 48
Joined: 04. January 2003 17:18
Location: /root

Postby Wiedmann » 25. May 2004 13:16

NoFear wrote:bei mir ist das nicht der fall, wenn keine index.html vorhanden ist zeigt er zugriff verweigert an.


mckinley wrote:das kannst du einstellen in der httpd.conf
in dem <directory ></directory> abschnitt


Innerhalb des <Directory> - Abschnittes der zu deinem htdocs-Verzeichnis gehört, gibt es eine Anweisung "Options". Da hängst du dann noch den Parameter "+Indexes" an. Das Modul "mod_autoindex" muß dazu auch geladen sein.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Next

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests