CGI unter Apache 2.0

Alles, was den Apache betrifft, kann hier besprochen werden.

CGI unter Apache 2.0

Postby klaus1 » 29. April 2004 19:31

Hi Leute!

Ich brauche eure Hilfe!
Ich versuche verzweifelt CGI-Skripts in meinen Apache Server einzubinden, jedoch ohne Erfolg.
Mein Server ist installiert unter:
"C:/Apache/Apache2" dort dann die einzelnen ordner cgi-bin, bin, conf usw..

Um CGI zu aktivieren hab ich gelesen, dass ich also folgenden Eintrag machen muss, bzw. ändern muss:
ScriptAlias /cgi-bin/ "C:/Apache/Apache2/cgi-bin/"

Ist das eigentlich alles, weil wenn ich dann versuche ein Skript zu starten, dann klappt das irgendwie nicht.. es kommt folgende Fehlermeldung:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, klaus and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


--------------------------------------------------------------------------------

Apache/2.0.43 Server at klaus1 Port 80
klaus1
 
Posts: 3
Joined: 29. April 2004 19:25
Location: Schörfling am Attersee

folgendes ist konfiguriert

Postby klaus1 » 29. April 2004 19:49

Hier ein Auszug aus der Konfigurierung...

Bekomme allderdings immer noch einen Fehler!


# ScriptAlias: This controls which directories contain server scripts.
# ScriptAliases are essentially the same as Aliases, except that
# documents in the realname directory are treated as applications and
# run by the server when requested rather than as documents sent to the client.
# The same rules about trailing "/" apply to ScriptAlias directives as to
# Alias.
#
ScriptAlias /cgi-bin/ "C:/Apache/Apache2/cgi-bin/"

#ScriptAlias /cgi-bin/ "C:\Apache\Apache2\cgi-bin"
#
# "C:/Apache/Apache2/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "C:/Apache/Apache2/cgi-bin">
AllowOverride None
#Options None
Options ExecCGI
Order allow,deny
Allow from all
</Directory>
klaus1
 
Posts: 3
Joined: 29. April 2004 19:25
Location: Schörfling am Attersee

PROBLEM beseitigt...

Postby klaus1 » 10. May 2004 14:58

Für alle, die schon mal ähnliches erlebt haben...

die loadmodules müssen aufgerufen werden in der httpd.config sowie im modules ordner sollten doch eine .so dateien drinnen stehen, die man aufruft! :-)
MFG
Klaus
klaus1
 
Posts: 3
Joined: 29. April 2004 19:25
Location: Schörfling am Attersee


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests