SSI: $QUERY_STRING funktioniert nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

SSI: $QUERY_STRING funktioniert nicht

Postby juergen&lx » 02. May 2013 08:26

Moin zusammen,

ich versuche mich gerade an shtml.
Problem: mit nachstehendem Script erhalte ich immer diese Fehlermeldung: [an error occurred while processing this directive] .

Code: Select all
<h1>Dynamisches HTML mit Server Side Includes</h1>
<p>Diese Seite hat keine festgelegten Inhalte, sondern wird vom Server zusammengesetzt.</p>
<!--#if expr="$QUERY_STRING = 'test' " -->
<!--#set var="param" value="Sie haben die Seite mit dem test-Parameter aufgerufen" -->
<!--#echo var="param" -->
<!--#else -->
<!--#include virtual="test.inc" -->
<!--#endif -->
Ausgabe:
Dynamisches HTML mit Server Side Includes

Diese Seite hat keine festgelegten Inhalte, sondern wird vom Server zusammengesetzt.
[an error occurred while processing this directive] Sie haben die Seite mit dem test-Parameter aufgerufen

Hat jemand eine Idee?
Jürgen
juergen&lx
 
Posts: 154
Joined: 18. February 2004 21:36
Location: in einem Dorf am Rande des Strombergs
Operating System: Linux

Re: SSI: $QUERY_STRING funktioniert nicht

Postby Nobbie » 04. May 2013 10:31

Was steht denn im error.log?

Unabhängig davon: wieso tust Du Dir die total veralteteten und klobigen SSI überhaupt noch an? Die haben definitiv keine Daseinsberechtigung mehr, die stammen noch aus Zeiten, wo es nicht einmal ein PHP gab. Ich würde da keine Sekunde mehr investieren, es gibt wirklich NICHTS, was damit irgendwie besser oder einfacher ginge als mit PHP.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests