Apache 2.4 linker errors on windows using VS 2008

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache 2.4 linker errors on windows using VS 2008

Postby SolidSnakeGTI » 16. May 2012 22:58

Question: Is there any manual/steps on how to build Apache for windows? The official documentation isn't sufficient. Or can I ask how do you build it yourself here @ Apache Friends?

I've tried to compile Apache HTTP Server 2.4 on windows using Visual Studio 2008 Professional on Windows 7 Service Pack 3, but with no hope at all!!
Already tested same steps with Apache HTTP Server 2.2 and had successful build process.

I don't know what's wrong, or what's missing. Here it is followed steps:

Code: Select all
Visual Studio 2008 Command Prompt:

"C:\Program Files\Microsoft Visual Studio 9.0\VC\bin\vcvars32.bat"

cd C:\path\to\httpd-2.4.2
   
perl srclib\apr\build\lineends.pl
   
perl srclib\apr\build\cvtdsp.pl -2005
   
cd srclib\zlib
nmake -f win32/Makefile.msc LOC="-DASMV -DASMINF -I." OBJA="inffas32.obj match686.obj"
MT -manifest zlib1.dll.manifest -outputresource:zlib1.dll;2
   
cd ..\..\srclib\openssl
perl Configure VC-WIN32 enable-camellia disable-idea
ms\do_nasm
nmake /f ms\ntdll.mak
   
Open Apache.dsw with VS9 "Yes to All" to the "convert projects" question, Select relase win32
Now build InstallBin
Test your build


Required libraries already in place:
Code: Select all
    srclib\apr
    srclib\apr-iconv
    srclib\apr-util
    srclib\openssl
    srclib\pcre
    srclib\zlib


As I said, all Apache HTTP Server 2.2 compilations are successful, while all Apache HTTP Server 2.4 is NOT.

This is the most occuring error, repeated over 100 times:

Code: Select all
fatal error LNK1181: cannot open input file '..\..\release\libhttpd.lib'


Other errors:
Code: Select all
    fatal error LNK1181: cannot open input file '..\release\mod_proxy_balancer.lib'
    fatal error LNK1181: cannot open input file '..\core\release\mod_watchdog.lib'
    fatal error C1083: Cannot open include file: 'pcre.h': No such file or directory   
    fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\Common7\ide\devenv.COM"' : return code '0x1'
    error PRJ0019: A tool returned an error code from "Performing Makefile project actions"



Any suggestions?

Environment: Windows 7 | Visual Studio 2008 | Cygin | Apache HTTP Server 2.4 Source | APR/APR-UTIL/APR-ICONV/ZLIB/OPENSSL


Note: I've noticed that there's multiple .mak file missing from the Apache 2.4 package, including the httpd.mak & others. I think that's big part of the problem.
SolidSnakeGTI
 
Posts: 1
Joined: 16. May 2012 22:55
XAMPP Version: 5.6.3
Operating System: Win7

Re: Apache 2.4 linker errors on windows using VS 2008

Postby JonB » 17. May 2012 01:47

Or can I ask how do you build it yourself here @ Apache Friends?


"they don't"

and there's a Beta with Apache 2.4

http://www.apachefriends.org/en/xampp-beta.html

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests