[solved]Web Ui macht problem

Alles, was den Apache betrifft, kann hier besprochen werden.

[solved]Web Ui macht problem

Postby snoop » 01. May 2012 14:33

Hallo zusammen

ich habe ein Problem und zwar wenn ich auf mein Web Ui von OSSEC(eine Host-IDS) versuche zuzugreifen, kommt immer eine Downloadsdatei..obwohl ich alles richtig konfiguriert habe...

Dabei habe ich diese Schritte eins zu eins befolgt:

Installing Apache

root@home:/# cd /tmp
root@home:/tmp# apt-get install apache2 libapache2-mod-php5 # said yes to all required packages
root@home:/tmp# /etc/init.d/apache2 restart
Downloading

root@home:/tmp# cd /var/www
root@home:/var/www# wget http://www.ossec.net/files/ui/ossec-wui-0.3.tar.gz
root@home:/var/www# wget http://www.ossec.net/files/ui/ossec-wui-0.3-checksum.txt
root@home:/var/www# md5sum -c ossec-wui-0.3-checksum.txt
root@home:/var/www# sha1sum -c ossec-wui-0.3-checksum.txt
Installing the wui

root@home:/var/www# tar -zxvf ossec-wui-0.3.tar.gz
root@home:/var/www# mv ossec-wui-0.3 ossec
root@home:/var/www# cd ossec
root@home:/var/www/ossec# ./setup.sh
To get the username that Apache is running

root@home:/var/www/ossec# ps auwx |grep apache | cut -d ” ” -f 1 | grep -v root | uniq
www-data
Adding www-data to ossec group and checking after

root@home:/var/www/ossec# usermod -a -G ossec www-data
root@home:/var/www/ossec# cat /etc/group |grep ossec
ossec:x:1001:www-data
Fixing ./tmp permissions

root@home:/var/www/ossec# chmod 770 tmp/
root@home:/var/www/ossec# chgrp www-data tmp/
root@home:/var/www/ossec# apache2ctl restart
That’s it! Just go to http://youripaddress/ossec to access it




Jedoch kann ich nicht auf die Seite zugreifen..weiss jemand von euch,was das problem sein könnte?

Danke für jede Hilfe
Last edited by snoop on 02. May 2012 12:43, edited 1 time in total.
snoop
 
Posts: 5
Joined: 20. April 2012 07:22
XAMPP Version: 1.8.3
Operating System: ubuntu 11.04

Re: Web Ui macht problem

Postby snoop » 02. May 2012 12:43

Das Problem konnte gelöst werden!
snoop
 
Posts: 5
Joined: 20. April 2012 07:22
XAMPP Version: 1.8.3
Operating System: ubuntu 11.04

Re: [solved]Web Ui macht problem

Postby Altrea » 02. May 2012 14:31

Hallo snoop,

Wäre noch schön, wenn du uns an deiner Lösung teilhaben lassen könntest, damit auch andere davon profitieren können.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: [solved]Web Ui macht problem

Postby snoop » 03. May 2012 17:13

Das Problem lag, dass ich PHP auf meinem Server nicht drauf hatte. Die Downloadsdatei war irgendein PHP File. Nachdem ich php5-common und php5-cli packages installiert hab und die Services apache etc. neugestaret hab, ist es wieder gegangen :)
snoop
 
Posts: 5
Joined: 20. April 2012 07:22
XAMPP Version: 1.8.3
Operating System: ubuntu 11.04


Return to Apache

Who is online

Users browsing this forum: No registered users and 1 guest