proxypass issue in apache Server

Alles, was den Apache betrifft, kann hier besprochen werden.

proxypass issue in apache Server

Postby sharma251185 » 10. April 2012 09:43

Hello

I've pass my one site to another site. Its working nice but on some link its displaying original Link. Here is my configuration

Original Site "mysite.com"


Second Site Configuration which is proxypassed on "mysite.com"
<VirtualHost *:80>
ServerName test.mysite.com
ServerAlias www.test.mysite.com test.mysite.com
ErrorLog /var/log/apache2/test.mysite_log.log
TransferLog /var/log/apache2/test.mysite-access_log.log
LogLevel info
LogFormat "%h %l %u %t \"%r\" %>s %b %T" common
ProxyPreserveHost On
ProxyPass / http://mysite.com/
ProxyPassReverse / http://mysite.com/

</VirtualHost>




Now, everything is working well. But the problem is that when I go to some specific link its redirect me to original link. For Example

there are two section on my page "about-us" and "inquiry"

When I click on "about-us" its take me to "http://test.mysite.com/about-us" which is ok

When I click on "inquiry" its take me to "http://mysite.com/inquiry" which is not correct it must be "http://test.mysite.com/inquiry"


I think I've missed some thing to add in configuration file but I cant figure it out.

Please look into this matter and help me.
sharma251185
 
Posts: 1
Joined: 10. April 2012 09:41
XAMPP Version: 1.8.2-2
Operating System: Linux

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests