Website auf neuen Rechner umgezogen, Apache neu, nix geht

Alles, was den Apache betrifft, kann hier besprochen werden.

Website auf neuen Rechner umgezogen, Apache neu, nix geht

Postby paneu » 26. March 2012 10:55

Hallo Mitforende,

Ich bin echt am Verzweifeln :x

Ich kann halbwegs html schreiben und 'nen ftp-Server bedienen. Jetzt habe ich aber eine richtiges Problem:

Ich habe eine alte Website, die mit shtml-Dateien aufgebaut ist. Dazu gehört eine Apache conf-datei mit Anweisungen, damit ich die Anzeige der Website lokal auf meinem Rechner überprüfen kann (die conf-Datei hat mir damals jemand eingerichtet).

Jetzt habe ich einen neuen Rechner und die komplette Wesbite dahin verfrachtet, Apache neu runtergeladen und installiert. Ich kriege es aber nicht hin, die Änderungen korrekt in der conf-Datei vorzunehmen. (Website soll nur lokal laufen.)

Ich probiere jetzt seit drei Tagen das Ganze wieder ans Laufen zu bringen, habe mich durch diverse Anleitungen gewühlt aber ich kriege es nicht hin :cry: :cry: :cry: . Wahrscheinlich steht hier auch eine Menge an Tipps aber ich habe keine Nerven mehr, noch mehr zu lesen. Deswegen entschuldigt bitte, daß ich nicht die "Suche" konsultiert habe sondern direkt einen "Hilfeschrei" loslasse.

Hier habe ich jetzt noch mal das hinkopiert, was in der alten Version der conf-datei dazugeschrieben worden war. Ich mußte dann im Browser einen Pfad eingeben und die Website wurde angezeigt. Ich habe seit 2,5 Jahren nix mehr an der Website gemacht und komme mir so was von alzheimerisch vor, denn ich erinnere jetzt nicht mal mehr, wie ich diese "alias"-Anweisung ich in der Browserzeile eingeben mußte, damit der Webserver verstand, was ich von ihm wollte.

Hier ist das, was damals in der conf-Datei ergänzt wurde:

Alias /_test_ "D:\Website"
<Directory "d:\Website">
Options Includes
Order allow,deny
Allow from all
</Directory>

Alias /_test1_ "D:\Website"
<Directory "d:\Website\e">
Options Includes
Order allow,deny
Allow from all
</Directory>

Alias /_test2_ "D:\Website\"
<Directory "d:\Website\ADS">
Options Includes
Order allow,deny
Allow from all
</Directory>

Ich habe versucht, den neuen Pfad einzugeben (zu dem Verzeichnis, wo die index-Datei jetzt liegt):

<Directory "C:\Website-LC\d\welcome">
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
AddOutputFilter INCLUDES .shtml .shtm
</Directory>

Alias /_test_ "C:\Website-LC\d\welcome"
<Directory "c:\Website-LC">
Options Includes
Order allow,deny
Allow from all
</Directory>

Aber es klappt nicht.

Vielleicht sieht jemand, der von Programmieren Ahnung hat, was mein Fehler ist.

Der Apache läuft übrigens. Das habe ich getestet.

Danke vielmals im Voraus für eure Hilfestellung!

Paneu
paneu
 
Posts: 1
Joined: 26. March 2012 10:21
XAMPP Version: 5.6.3
Operating System: Windows

Return to Apache

Who is online

Users browsing this forum: No registered users and 8 guests