Apache 2 auf OpenSuse 12.1 eingerichtet - Ist das so korrekt

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache 2 auf OpenSuse 12.1 eingerichtet - Ist das so korrekt

Postby unleash » 08. March 2012 20:22

Hallo und guten Morgen Apache-Freunde,

Wer legt denn das Verzeichnis
Code: Select all
  ~/username/public_html.
an- und wann - also zu welchem Zeitpunkt.

Frage; War das bei der Installation von OpenSuse 12.1 angelegt worden oder war es erst beim Einrichten des Apache2 angelegt worden. Übrigens ist da auch das mit einem speziellen Icon ausgestattet - da ist im
Dolphin ein Icon drauf auf (/ein Web-symbol).


Also - ich bin etwas ratlos. Hab den http-server Apache 2 vor einer Woche eingerichtet

auf der Seite 3 /r 4 der Konfiguration von Apache habe ich diese Angaben:

Code: Select all
Document Root: "/srv/www/htdocs"
Directory; "/srv/www/htdocs"
Alias: /icons/ "/usr/share/apache2/icons/"
Directory: "/usr/share/apache2/icons"
Script Alias: /cgi-bin/ "/srv/www/cgi-bin/"
Directory: "/srv/www/cgi-bin"
mod_userdir.c: empty here nothing is filled in ;-)
include: /etc/apache2/conf.d/*.conf
include: /etc/apache2/conf.d/apache2-manual?conf
Servername linux-r4qe
E-Mail des Servername: root@linux-r4qe

auf der Seite 5/5

Code: Select all
listening on
all, port 80
Standardhost
in
SSL deaktiviert
Virtuelle Hosts
linux-r4qe in "/srv/www/htdocs", SSL deaktiviert

hoffe ich hab den Apache 2 jetzt richtig eingerichtet.


Hab das nämlich früher mal falsch installiert
Code: Select all
public $unicodeslugs = '0';
    public $feed_limit = '10';
    public $log_path = '/srv/www/htdocs/basic/logs';
    public $tmp_path = '/srv/www/htdocs/basic/tmp';
    public $lifetime = '15';
    public $session_handler = 'database';
}



Das führte zu Troubles -zb. Permission-Fehler
Dabei ist wenn man es normal in openSUSE installiert dann wird ein Apache oder ein LAMP normalierweise dahin installiert oder

Code: Select all
    ~/username/public_html.


Oder zumindest ist der Document-rooot da.


im übringen ist das hier auch angelegt:

[PHP] ~/username/public_html.[/PHP]

Jetzt ist da ein WWW-Symbol auf dem Ornder drauf - ist das so in ordnung!?


Also - nochmals konkret; ich bin voll am Schwimmen: hatte das ganz schomma installiert - dann war der Apache bei einer anderen - alten - früheren installation hier dirnne:

Code: Select all
    public $log_path = '/srv/www/htdocs/basic/logs';


genauer gesagt hier die daten:

Code: Select all
public $unicodeslugs = '0';
    public $feed_limit = '10';
    public $log_path = '/srv/www/htdocs/basic/logs';
    public $tmp_path = '/srv/www/htdocs/basic/tmp';
    public $lifetime = '15';
    public $session_handler = 'database';
}



hab ich das mit den oben genannten werten - (und der neuen Einrichtung des Apache2 ) in OpenSuse 12.1 jetzt besser hingekriegt!?

auf der Seite 3 /r 4 der Konfiguration von Apache habe ich diese Angaben:

Code: Select all
Document Root: "/srv/www/htdocs"
Directory; "/srv/www/htdocs"
Alias: /icons/ "/usr/share/apache2/icons/"
Directory: "/usr/share/apache2/icons"
Script Alias: /cgi-bin/ "/srv/www/cgi-bin/"
Directory: "/srv/www/cgi-bin"
mod_userdir.c: empty here nothing is filled in ;-)
include: /etc/apache2/conf.d/*.conf
include: /etc/apache2/conf.d/apache2-manual?conf
Servername linux-r4qe
E-Mail des Servername: root@linux-r4qe


- dürft jetzt besser sein oder!?



Wenn ja - dann versteh ich das so dass ich jetzt hier in dieses verzeichnis hinein mein

Code: Select all
 ~/username/public_html.


Hmm --- da liegt sicherlich keine Apacheinstallation, nicht einmal eine DocRoot. Das ist das Ergebnis des erfolgreich geladenen Moduls mod_userdir.
Also ich denke, in der URL ist im Grunde ja eigentlich ein Slash zuviel, bin mir aber nicht ganz sicher, weil auch dies funzen könnte, wenns auf's Filesystem und nicht auf ne URL geht.
Auch wenn dann ein doppelter Username im Pfad existieren müßte, was komisch aussieht.
Was meint ihr denn!?
unleash
 
Posts: 132
Joined: 03. December 2011 10:16
XAMPP Version: 5.6.3
Operating System: OpenSuse Linux 12.1

Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests