http klappt, https klappt nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

http klappt, https klappt nicht

Postby beisss » 12. January 2012 13:24

Hallo,

ich hab mir einen Apache Webserver aufgesetzt und eine SSL-Verschlüsselung eingerichtet. Dazu habe ich mir ein Zertifikat erstellt und es mir selbst signiert. So weit so gut.

Wenn ich nun mit Firefox meine Startseite besuche bekomme ich diese auch ausgeliefert (http://localhost). Will ich nun das gleiche mit https versuchen (https://localhost) bekomme ich nach den üblichen Warnungen, dass das eine nicht vertrauenswürdige Site ist (Ich hab mir ja das Zertifikat selbst ausgestellt) und der Bestätigung "Ich kenne das Risiko" die Fehlermeldung "403 Forbidden".

Dieser ganze Vorgang sagt mir eigentlich das https funktioniert (?), jedoch warum der Webserver mir die Startseite dann nicht ausliefert verstehe ich nicht. Ein prinzipielles Problem mit der Startseite habe ich nicht da es mit http://localhost funktioniert.
Ich hab mir mal die access.log angeschaut. Darin findet sich der Eintrag
Code: Select all
127.0.0.1 - - [12/Jan/2012:12:22:37 +0100] "GET / HTTP/1.1" 403 202

was kann das für Ursachen haben? Und wie kann ich dahinterkommen?

Aufschlussreicher ist da schon die error.log Wenn ich den Apache starte sind da Warnings drinn:
Code: Select all
[Thu Jan 12 12:27:53 2012] [notice] Parent: Received restart signal -- Restarting the server.
[Thu Jan 12 12:27:53 2012] [notice] Child 3308: Exit event signaled. Child process is ending.
Warning: DocumentRoot [C:/Server/Apache2.2/htdocs] does not exist
[Thu Jan 12 12:27:53 2012] [notice] Apache/2.2.21 (Win32) DAV/2 mod_auth_sspi/1.0.4 mod_ssl/2.2.21 OpenSSL/0.9.8r SVN/1.7.2 configured -- resuming normal operations
[Thu Jan 12 12:27:53 2012] [notice] Server built: Sep  9 2011 10:26:10
[Thu Jan 12 12:27:53 2012] [notice] Parent: Created child process 2148
Warning: DocumentRoot [C:/Server/Apache2.2/htdocs] does not exist
Warning: DocumentRoot [C:/Server/Apache2.2/htdocs] does not exist
[Thu Jan 12 12:27:54 2012] [notice] Child 2148: Child process is running
[Thu Jan 12 12:27:54 2012] [notice] Child 2148: Acquired the start mutex.
[Thu Jan 12 12:27:54 2012] [notice] Child 2148: Starting 64 worker threads.
[Thu Jan 12 12:27:54 2012] [notice] Child 3308: Released the start mutex
[Thu Jan 12 12:27:55 2012] [notice] Child 3308: All worker threads have exited.
[Thu Jan 12 12:27:55 2012] [notice] Child 3308: Child process is exiting
[Thu Jan 12 12:27:55 2012] [notice] Child 2148: Starting thread to listen on port 443.
[Thu Jan 12 12:27:55 2012] [notice] Child 2148: Starting thread to listen on port 80.


Hier sagt er mir das das Verzeichnis C:/Server/Apache2.2/htdocs nicht existiert, was jedoch nicht stimmt. Ich kann die darinliegende Startseite ja auch abrufen (http://localhost).

Nun die Frage: was geht schief?

Übrigens in der http.conf ist der Eintrag
Code: Select all
DocumentRoot "C:/Server/htdocs"


wiso es dann zur Warnung:
Code: Select all
Warning: DocumentRoot [C:/Server/Apache2.2/htdocs] does not exist

kommt ist mir nicht klar.

Danke für Eure Hilfe!
beisss
 
Posts: 2
Joined: 12. January 2012 12:02
XAMPP Version: 1.7.1
Operating System: Windows 6.1.7601

Re: http klappt, https klappt nicht

Postby Altrea » 12. January 2012 18:05

Hallo beisss,

Ich habe deinen Beitrag mal dahin verschoben wo er hingehört. Ins Forum "Apache Friends" gehören nur Themen rund um das Projekt Apache Friends. Das nächste Mal also bitte etwas Zeit nehmen, das richtige Forum für dein Thema zu wählen.

Zum Thema:
Da HTTPS einen eigenen Port und bestimmte eigene Parameter erfordert, gliedert man die SSL Konfiguration für gewöhnlich in einen VirtualHost aus, der sich für alle Anfragen auf den Standardport 443 zuständig fühlt. In so einem VirtualHost würde man dann auch den DocumentRoot definieren. Ob man diesen auf denselben Pfad legt wie für HTTP Anfragen oder nicht, bleibt einem selbst überlassen.

Der HTTP Fehler 443 deutet darauf hin, dass für dieses Verzeichnis keine autoindex Option gesetzt wurde und das Verzeichnis keines der definierten DirectoryIndex Dateien enthält (sofern welche definiert wurden). Ein Status 443 kann aber noch ganz andere Gründe haben.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6691
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: http klappt, https klappt nicht

Postby beisss » 13. January 2012 08:40

Hallo Altrea,

dass meine Frage im falschen Forum gelandet ist tut mir leid, es war ein Versehen. Normalerweise weis ich mich in einem Forum zu benehmen.

Zum Problem: Danke für Deinen Hinweis mit dem VirtualHost. Da hat's bei mir geklingelt. Alles was zu tun war ist einfach in der httpd-ssl.conf den Eintrag DocumentRoot anzupassen:

Code: Select all
DocumentRoot "C:/Server/htdocs"


Das war es dann auch schon. In der error.log bin ich ja schon fast mit der Nase drauf gedrückt worden.

Danke für Deine Hilfe!

Grüße
beisss
beisss
 
Posts: 2
Joined: 12. January 2012 12:02
XAMPP Version: 1.7.1
Operating System: Windows 6.1.7601


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests