[gelöst]Apache2 reagiert nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

[gelöst]Apache2 reagiert nicht

Postby towen » 14. December 2011 09:17

Hallo,
ich habe ein merkwürdiges Problem, finde einfach keine Lösung und hoffe hier auf einen entsprechenden Hinweis.

Habe einen Server, wo sich alle paar Minuten der Apache verabschiedet hat. Das bedeutet, ich konnte keine Webseite mehr aufrufen, der Apache selber, war aber noch aktiv. Dieses passierte alle paar Minuten und ist für ein produktives System natürlich tödlich.
Der Server ist schon 2 Jahre im Betrieb und die eine oder andere Fehlkonfiguration ist nicht auszuschliessen.

Daher habe ich jetzt einen neuen Server bestellt und begonnen, die ganzen Projekte auf den neuen Server zu ziehen.
Jetzt fängt dieses Problem bei dem neuen Server auch an - Apache läuft, ich kann aber keine Webseite aufrufen. Erst nach einem Restart des Apache läuft wieder alles rund.
Bei dem neuen Server trifft dieses Problem nur sporadisch auf - diesmal heute Nacht, innerhalb von 8 Stunden ist es passiert.

Da dieses Problem auf dem alten Server jetzt verschwunden ist, vermute ich das es an einem meiner Projekte liegen könnte.
Ich habe aber keine Ahnung wie ich dieses herausfinden kann ...

Apache Dienst läuft, PID vorhaben, im Error Log kann ich nichts verdächtiges finden ...

Hat jemand eine Idee?


Gruß
Torsten
towen
 
Posts: 5
Joined: 14. December 2011 09:07
XAMPP Version: 5.6.3
Operating System: Debian 6.0

Re: Apache2 reagiert nicht

Postby Altrea » 14. December 2011 15:01

Hallo Torsten,

Durchsuch bitte mal das Ereignisprotokoll des Betriebssystems auf irgendwelche Fehlermeldungen.
Sollte sich auch dort nichts finden, werden auch wir hier nichts ausrichten können, dann wirst du dich auf den mühsamen Weg der Fehlersuche oder zumindest Fehlereingrenzung machen müssen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6538
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache2 reagiert nicht

Postby towen » 14. December 2011 17:11

Hallo Altrea,

ist etwas kompliziert, ist klar.
Bekomme aber gerade ein paar Tipps zum Thema im Debianforum - hoffe mal, dass ich dann den Fehler finde.


Danke & Gruß

Torsten
towen
 
Posts: 5
Joined: 14. December 2011 09:07
XAMPP Version: 5.6.3
Operating System: Debian 6.0

Re: Apache2 reagiert nicht

Postby Altrea » 14. December 2011 18:31

Ich hoffe du findest den Fehler.
Wäre schön, wenn du die Fehlerlösung dann auch hier zur Verfügung stellen würdest, damit andere Hilfesuchende die dasselbe Problem haben sich nicht auf dieselbe schwierige Fehlersuche machen müssen.

Ich drück dir die Daumen :)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6538
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache2 reagiert nicht

Postby towen » 14. December 2011 18:38

Werde ich machen, wenn ich weiss was los ist ;-)

Torsten
towen
 
Posts: 5
Joined: 14. December 2011 09:07
XAMPP Version: 5.6.3
Operating System: Debian 6.0

Re: Apache2 reagiert nicht

Postby towen » 16. December 2011 21:36

So - jetzt nach guten 48 Stunden möchte ich mal eine kurze Rückmeldung geben: Server läuft noch ;-)

Im Debianforum bekam ich den Tipp, das LogLevel auf "info" hochzusetzen und auch mal den Server mit "htop" zu überwachen.
Der Tipp mit dem LogLevel war sehr gut und hat mich in der Fehlersuche weiter gebracht:

Code: Select all
[Wed Dec 14 17:02:31 2011] [info] server seems busy, (you may need to increase StartServers, or Min/MaxSpareServers), spawning 8 children, there are 0 idle, and 12 total children


Meine Änderungen an der httpd.conf waren scheinbar die Lösung:

Code: Select all
KeepAlive On
MaxKeepAliveRequests 1000
KeepAliveTimeout 3
<IfModule mpm_prefork_module>
    ServerLimit          512
    StartServers          50
    MinSpareServers        5
    MaxSpareServers      250
    MaxClients           500
    MaxRequestsPerChild 4000
</IfModule>


Die Werte sind etwas hoch, aber mein Server kommt gut damit klar. Ich wollte mit dieser Einstellung testen, ob sich der Server besser oder noch schlechter verhält.

Ich hatte vor 2 Tagen dann noch mal ein gewaltiges Problem mit SQL, so dass ich am Ende den Server rebooten musste. Aber seit 49,5 Stunden läuft er sauber durch und es sind in dieser Zeit auch 40 weitere Wordpress Installationen auf diesen Server umgezogen worden. Alles in Allem befinden sich jetzt gute 150 Projekte (Blogs, Verzeichnisse, HTML Seiten, PHP Scripte) auf diesem Server.

Die Load liegt derzeit im Schnitt bei 1.50 und der Server nutzt kaum mehr als 8GB RAM.



Wünsche Euch frohe XMas und ein gutes neues Jahr.

Torsten
towen
 
Posts: 5
Joined: 14. December 2011 09:07
XAMPP Version: 5.6.3
Operating System: Debian 6.0

Re: Apache2 reagiert nicht

Postby Altrea » 17. December 2011 01:56

Hallo Torsten,

vielen Dank für die Rückmeldung. Das ist sehr Hilfreich :)
Dein Server verwaltet aber schon eine ganze Latte an Projekten.
Sind die alle frequentiert oder sind das Entwicklungsinstallationen?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6538
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache2 reagiert nicht

Postby towen » 17. December 2011 08:25

Altrea wrote:Sind die alle frequentiert oder sind das Entwicklungsinstallationen?


Guten Morgen Altrea,

sind alles bereits fertige Projekte die auch entsprechende Besucher haben - mal mehr, mal weniger ;-)


Gruß
Torsten
towen
 
Posts: 5
Joined: 14. December 2011 09:07
XAMPP Version: 5.6.3
Operating System: Debian 6.0


Return to Apache

Who is online

Users browsing this forum: No registered users and 9 guests