[gelöst] ModRewrite konfiguriert, aber tot

Alles, was den Apache betrifft, kann hier besprochen werden.

[gelöst] ModRewrite konfiguriert, aber tot

Postby Onsemeliot » 13. September 2011 15:56

Ich arbeite auf einem Debian Server (mit mehreren Domains) und bin der Beschreibung unter:
http://www.lavluda.com/2007/07/15/how-t ... 22-debian/
gefolgt um das Mod Rewrite Tool zu aktivieren.

Über SSH habe ich direkt am Server die Config-Daten bearbeitet und auch den Apache neu gestartet.

Wenn ich rewrite über: "a2enmod rewrite" aktiviere, bekomme ich nur noch die Rückmeldung, dass es bereits aktiviert ist. Auch unter "/etc/apache2/sites-available/default" habe ich die anscheinend korrekten Angaben (aus der erwähnten Beschreibung) stehen.

Dennoch zeigt mir phpinfo() keine Spur von "Loaded Modules" oder "mod rewrite". Wenn ich die phpinfo-Seite durchsuche finde ich keine Treffer mit diesen Schlagwörtern.

Sobald ich eine Rewrite-Regel in der .htaccess-Datei dafiniere, kann ich weder die Ursprungsseite, noch ihren neuen Namen erreichen (Error 404).

Dabei habe ich erst mal nur einen ganz banalen Test mit zwei statischen Dateinamen versucht:
Code: Select all
Options +FollowSymLinks
Options +Indexes
RewriteEngine On
RewriteRule index.php x.htm

Hat irgendwer eine Idee, was da falsch laufen könnte?
Last edited by Onsemeliot on 14. September 2011 15:24, edited 1 time in total.
Onsemeliot
 
Posts: 3
Joined: 13. September 2011 15:33

Re: ModRewrite konfiguriert, aber tot

Postby Nobbie » 13. September 2011 22:40

Onsemeliot wrote:Dennoch zeigt mir phpinfo() keine Spur von "Loaded Modules" oder "mod rewrite". Wenn ich die phpinfo-Seite durchsuche finde ich keine Treffer mit diesen Schlagwörtern.


Ist ja auch die total falsche Stelle, mod_rewrite hat NullKommaNull irgendetwas mit PHP zu tun, das ist ein Apache Modul, keine PHP Extension. Das eine hat mit dem anderen überhaupt rein gar nichts zu tun.

Onsemeliot wrote:Sobald ich eine Rewrite-Regel in der .htaccess-Datei dafiniere, kann ich weder die Ursprungsseite, noch ihren neuen Namen erreichen (Error 404).


Immerhin - das ist eigentlich ein Zeichen dafür, dass mod_rewrite wenigstens installiert ist und funktioniert, denn sonst würdest Du entweder gar keine Veränderung bemerken (falls .htaccess ignoriert wird) oder einen Serverfehler 500 bekommen (unbekannte Schlüsselworte). Aber ein Error 404 bedeutet, dass eine bestimmte Datei nicht gefunden wird (wahrscheinlich x.htm). Übrigens wird auf dieser Fehlermeldungsseite, wenn es die Standard Meldung von Apache im Auslieferungszustand ist (denn auch die Fehlermeldungen sind anpassbar), die verwendete Apache Version und(!) die von Apache geladenen Module aufgezählt.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: ModRewrite konfiguriert, aber tot

Postby Onsemeliot » 14. September 2011 14:34

Hallo Nobbie,

erst mal danke für die Antwort.

Mir ist klar, dass ModRewrite ein Apache-Modul ist. Allerdings bedeutet das ja nicht, dass phpinfo nicht auch diesbezüglich die Apache-Konfiguration anzeigen könnte. Und es war ja nicht meine Idee die Bestätigung über die phpinfo-Seite zu suchen, sondern das fand ich in verschiedenen Tutorials als Empfehlung um zu prüfen ob das Modul aktiviert ist.

Leider werden auf unserem Server nicht die Standard-Fehlermeldungen angezeigt. Aber die Apache-Version ist 2.2.9 (Debian).

Könnte das ModRewrite-Problem eventuell daher kommen, dass auf dem Server mehrere Domains laufen und auch Apache für jede virtuelle Domain eine eigene Konfigurationsdatei verwendet? (Ich hatte vor Kurzen das Problem die Session Lifetime pro Domäne anpassen zu müssen und konnte das Problem erst lösen indem ich in die jeweiligen Variablen der Domänen anstatt in der globalen Konfiguration anpasste.)
Onsemeliot
 
Posts: 3
Joined: 13. September 2011 15:33

Re: ModRewrite konfiguriert, aber tot

Postby Onsemeliot » 14. September 2011 15:23

Huch, ich bin wirklich doof:

Ich hatte die Reihenfolge durcheinander gebracht. Es funktioniert ohnehin.

Ich hatte dummer Weise an erster Stelle die Zieldatei und erst an zweiter Stelle den gewünschten Namen geschrieben, der in der Adresszeile angezeigt werden soll. In der richtigen Reihenfolge funktioniert's...
Onsemeliot
 
Posts: 3
Joined: 13. September 2011 15:33


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests