mehrere Vhost eine IP Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

mehrere Vhost eine IP Problem

Postby livingstone » 06. August 2011 01:25

Hallo zusammen,
ich bin hier neu in dem Forum, daher weiss ich grad auch nicht ob mein Post hier angebracht ist.
Bitte entschuldigt falls ich etwas Falsch gemacht habe.

Zu meinem Problem:
Ich habe einen Webserver und einige A-Record verweisen.
Es geht in erster Linie um drei verweise.
foo.domain1.com
bar.domain1.com
foo.domain2.com

Der Server den ich habe hat nur eine ip.

foo.domain1.com soll mit SSL verschlüsselt werden (zudem habe ich auch htaccess aktiviert)
Root directory ist /home/httpd/html/sub/
Zu dem Vhost funzt alles super.

die anderen beiden domain namen sollen unverschlüsselt über port 80 sein.

die vhost zu bar.domain1.com ist:

Code: Select all
<VirtualHost 192.168.40.253:80>
ServerName bar.domain1.com
DocumentRoot "/home/httpd/html/bardomain1/"

<Directory /home/httpd/html/bardomain1>
AllowOverride None
</Directory>
</VirtualHost>


vhost für foo.domain2.com ist:
Code: Select all
<VirtualHost 192.168.40.253:80>
ServerName foo.domain2.com

RewriteEngine on
RewriteRule     ^(.*)$     http://192.168.40.121$1 [P]
</VirtualHost>

Die Rewrte rule ist dazu weil es an einem anderen Rechner weitergeleitet werden soll.

Leider funktioniert das so nicht.
Ich lande immer bei foo.domain1.com und dann greift der htaccess.
Wenn ich bei bar.domain1.com 443 als port eintrage dann funktioniert es. Das will ich aber nicht.

Wäre super wenn mir jemand helfen könnte.
Falls noch welche infos nötig sind, kann ich die einreichen.

Viele Grüße
L.
livingstone
 
Posts: 3
Joined: 06. August 2011 01:05

Re: mehrere Vhost eine IP Problem

Postby Nobbie » 06. August 2011 10:30

livingstone wrote:Falls noch welche infos nötig sind, kann ich die einreichen.


Bitte zeige uns die VOLLSTÄNDIGE VirtualHost Konfiguration.

Und bei der RewriteRule glaube ich nicht, dass die funktioniert. Aus meiner Sicht fehlt da mindestens ein Slash vor dem $1. Und wieso benutzt Du in diesem Fall nicht die sinnvollere Alternative ProxyPass?
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: mehrere Vhost eine IP Problem

Postby livingstone » 06. August 2011 14:14

HI,

hier ist meine Vhost config
Code: Select all
#
# This is the Apache server configuration file providing SSL support.
Listen 443

#
#   Some MIME-types for downloading Certificates and CRLs
#
AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl    .crl

#   Pass Phrase Dialog:
SSLPassPhraseDialog  builtin

#   Inter-Process Session Cache:
#SSLSessionCache         "dbm:/var/run/httpd/ssl_scache"
SSLSessionCache        "shmcb:/var/run/httpd/ssl_scache(512000)"
SSLSessionCacheTimeout  300

#   Semaphore:
SSLMutex  "file:/var/run/httpd/ssl_mutex"

##
## SSL Virtual Host Context
##

NameVirtualHost 192.168.40.253:80
NameVirtualHost 192.168.40.253:443

<VirtualHost 192.168.40.253:443>

#   General setup for the virtual host
DocumentRoot "/home/httpd/html/subfolder/"

ServerName foo.domain1.com:443

ErrorLog "/var/log/httpd/error_log"
TransferLog "/var/log/httpd/access_log"

SSLEngine on

SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL

SSLCertificateFile "/etc/httpd/conf/server.crt"

#   Server Private Key:
SSLCertificateKeyFile "/etc/httpd/conf/server.key"


<FilesMatch "\.(cgi|shtml|phtml|php)$">
    SSLOptions +StdEnvVars
</FilesMatch>
<Directory "/srv/http/cgi-bin">
    SSLOptions +StdEnvVars
</Directory>


BrowserMatch ".*MSIE.*" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0

#   Per-Server Logging:
CustomLog "/var/log/httpd/ssl_request_log" \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

<Directory /home/httpd/html/subfolder>
    AuthType Basic
    AuthName "Password Required"
    AuthUserFile /data/development/svnrepos/.svn-auth-file
    Require valid-user
</Directory>

<Location /svn>
   DAV svn
   SVNParentPath /data/development/svnrepos
   AuthzSVNAccessFile /data/development/svnrepos/.svn-policy-file
   AuthName "SVN Repositories"
   AuthType Basic
   AuthUserFile /data/development/svnrepos/.svn-auth-file
   Satisfy Any
   Require valid-user
</Location>

</VirtualHost>                                 


<VirtualHost 192.168.40.253:80>
ServerName bar.domain1.com

DocumentRoot "/home/httpd/html/bardomain1/"
ErrorLog /var/log/httpd/error_log

<Directory /home/httpd/html/bardomain1>
AllowOverride All
</Directory>
</VirtualHost>


<VirtualHost 192.168.40.253:80>
ServerName foo.domain2.com
RewriteEngine on
RewriteRule     ^(.*)$     http://192.168.40.121$1 [P]
</VirtualHost>


Das Rewrite funktioniert soweit. Das habe ich schon ohne den zweiten VHost eintrag getestet.
Wenn ich bei dem zweiten VHost eintrag statt der :80 :443 eintrage funktioniert es. Aber möchte da ja keine SSL.
Ich kannte das ProxyPass nicht:) Werd mich dazu einlesen. Danke für den Tipp.

Grüße
L.
livingstone
 
Posts: 3
Joined: 06. August 2011 01:05

Re: mehrere Vhost eine IP Problem

Postby Nobbie » 06. August 2011 22:42

Sind das auch wirklich die Originaldaten (Domain, IP), oder sind das hier Pseudodaten?

Hast Du mal im error log geschaut (oder auch Apache mit Option "-S" gestartet), ob es ggf. einen Fehler in einer VirtualHost Deklaration gibt?

Und wo steht die Listen Anweisung für Port 80?

Und wozu gibt es einen NameVirtualHost für 192.168.40.253:443?
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: mehrere Vhost eine IP Problem

Postby livingstone » 06. August 2011 23:12

Hi,
Die domains sind pseudo namen.
Die ip ist richtig. Ja, ich weiss es ist eine LAN ip. Lasst mich das eben erklären:
Der Server steht hinter einem Router. Der Router hat eine statische Inet ip. Der ist auch so konfiguriert,
dass er alle anfragen bzgl port 80 und 443 an den Rechner weiterleitet.

In Log habe ich noch nicht geschaut. Werde ich machen und das Ergebniss auch noch mal hier Posten.
Ebenfalls habe ich Apache nicht mit -S gestartet. Werd das auch nachholen
Listen 80 hatte ich mal drin aber das hatte mir auch nichts gebracht.
Der Eintrag war schon vorhanden. Brauch man den nicht?

Ich habe ebenfalls in der Dokumentation von Apache bei "Unterstützung namensbasierter virtueller Hosts" folgendes gelesen:
Namensbasierte virtuelle Hosts können aufgrund der Natur des SSL-Protokolls nicht mit SSL-gesicherten Servern verwendet werden.

Trifft es auf mein Problem zu?

Grüße
L.
livingstone
 
Posts: 3
Joined: 06. August 2011 01:05

Re: mehrere Vhost eine IP Problem

Postby Nobbie » 06. August 2011 23:26

livingstone wrote:Ich habe ebenfalls in der Dokumentation von Apache bei "Unterstützung namensbasierter virtueller Hosts" folgendes gelesen:
Namensbasierte virtuelle Hosts können aufgrund der Natur des SSL-Protokolls nicht mit SSL-gesicherten Servern verwendet werden.

Trifft es auf mein Problem zu?


Nein. Ich würde aber die NameVirtualHost Anweisung für Port 443 ersatzlos löschen, sie wird nicht benötigt und könnte allenfalls auch eine Fehlerursache darstellen.

Allerdings habe ich mir endgültig abgewöhnt, bei "Pseudo" Konfigurationen Hilfestellung zu geben. In 99% aller Fälle wird nämlich vom Anwender durch die "verpseudosierung" (natürlich ungewollt und unwissentlich) die eigentliche Fehlerursache verschleiert, so dass eine Fehlersuche von vorneherein nicht zum Erfolg führen kann. Das ist so nervig und frustierend, dass ich mich grundsätzlich zu diesem Schritt entschlossen habe.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests