Need help setting up apache !!! PLEASE

Alles, was den Apache betrifft, kann hier besprochen werden.

Need help setting up apache !!! PLEASE

Postby alinashul » 28. July 2011 21:34

Guyz , I'M DONE.I don't know what to do anymore. For 18 hours i'm standing infront of the PC and try to figure it out what the hell should i do to fix my problem.

I reinstalled my xampp pack, but now i can use RELATIVE LINKS in dreamweaver anymore .

I mean , i have htdocs and in that folder i placed another folder called WWW ( here i keep all my projects ).I have put in apache conf file that this is the root folder , but when i try to use dreamweaver with relative link it's not working at all.
Before reinstalling XAMPP all i had to do was create a new folder in WWW folder and start working at my project and relative link ware working.But now they are not . For example if i would have folder called MYSITE and i wanted to put on a page an image that is located in the images folder within the MYSITE folder i would've used images/picture.jpg , but now it's not working.


The actual project that i work is in folder called rotutscms located in the WWW folder . As i mentioned before in conf file from apache i have DocumentRoot "E:/xampp/htdocs/www/" now if i use wordpress function <?php echo get_template_directory_uri(); ?> i'll get this : <img src="http://localhost/www/rotutscms/wp-content/themes/rotuts/images/HTML.png"/> which it returns an error since the "localhost" is localhost/www . So the correct link that this function should return is http://localhost/rotutscms/wp-content/t ... s/HTML.png .

Do you guyz understand what's my problem ?
alinashul
 
Posts: 2
Joined: 28. July 2011 21:07

Re: Need help setting up apache !!! PLEASE

Postby Sharley » 29. July 2011 06:26

Drop the / at the end of the path from
Code: Select all
DocumentRoot "E:/xampp/htdocs/www/"
to
Code: Select all
DocumentRoot "E:/xampp/htdocs/www"


Did you also change this section further down the httpd.conf file?
Code: Select all
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "E:/xampp/htdocs">
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Need help setting up apache !!! PLEASE

Postby alinashul » 01. September 2011 08:43

Did you also change this section further down the httpd.conf file?
Code: Select all
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "E:/xampp/htdocs">
[/quote]

On that section i have this : <Directory "E:/xampp/htdocs/www">

Should i cut the /www out ?
alinashul
 
Posts: 2
Joined: 28. July 2011 21:07


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests