Apache ProxyPass not showing CSS files

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache ProxyPass not showing CSS files

Postby Priss » 13. July 2011 11:47

Hi, I have problem with the ProxyPass using Apache2 2.2 on a linuxSuse.

The setup is simpel I have one machine in the front that is doing a proxypass to another apache2 server (the web sever). Though when I do this for some reason the CSS doesn't load properly and the links that appear if clicked cast an internal server error 500.

Connecting directly to the web server works perfectly so this is why I assume there is something wrong with the proxypass.

The proxy server vhost file:
<VirtualHost *:80>
ServerName test.test.se

ProxyPass / http://10.100.20.31/
ProxyPassReverse / http://10.100.20.31/
</VirtualHost>

The web-server on the other hand catch the / and route it to document root which is my website:

webserver default config:
DocumentRoot "/srv/www/htdocs"

#
# Configure the DocumentRoot
#

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

<Directory "/srv/www/htdocs">
Order allow,deny
Allow from all
</Directory>

I thought it would be this simple to use the proxypass and I looked around quite a lot seems like this is a general problem but no1 can point out the error.
Priss
 
Posts: 2
Joined: 13. July 2011 11:35

Re: Apache ProxyPass not showing CSS files

Postby Priss » 13. July 2011 16:44

I solved the problem some what though another occur! To solve the first part simple add

ProxyPass /css !
ProxyPass /images !

after that it all worked except that I got an ugly IP in the web URL browser so I added
ProxyPreserveHost on

This lead to that the CSS is loading but the images ain't! I tried to add proxy_http to both apache servers but nothing.

Any ideas?
Priss
 
Posts: 2
Joined: 13. July 2011 11:35


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests