Interner Serverfehler wenn mod_rewrite

Alles, was den Apache betrifft, kann hier besprochen werden.

Interner Serverfehler wenn mod_rewrite

Postby Dani Düsentrieb » 14. June 2011 08:29

Hallo Leute

ich habe hier ein Problem mit meiner xampp installation.
Folgende umstände sind in meiner Installation eingerichtet. Xampp läuft parallel zum ISS auf einem Windows Server 2008 R2. Xampp ist so eingerichtet das er auf Port 8080 antwortet was zur folge hat das ich immer im Browser http://server:8080 angebe. Das funktioniert sowiet alles. Das htdocs verzeichnis vom Webserver musste auf ein anderes Verzeichnis auf einem anderen Laufwerk verschoben werden. Die Konfiguration ist aber soweit wie ich diese eingerichtet habe uach i.o. PHP klappt MySQL klappt, phpmyadmin über das xampp läuft, der Status von Xampp wird auf der Webseite angezeigt.
Nun habe ich mir das Wordpress auf dem Server installiert und jedesmal wenn ich die Permalinks aktivieren will kommt ein Interner Serverfehler. Dieser wird durch die .htaccess hervorgerufen die das Script in der Wordpress root erstellt um der mod_rewrite zu regeln.
Mod_rewrite ist ja Standardmäßig schon aktiviert und ich habe mir in der httpd.conf die entsprechenden Stellen angeschaut. Da denke ich passt soweit alles! Das bedeutet:

LoadModule rewrite_module modules/mod_rewrite.so
und später weiter unten in der Datei:
<Directory />
Options FollowSymLinks
AllowOverride All
Order deny,allow
Deny from all
</Directory>

Bin für alle Hinweise Dankbar!

Gruß Daniel
Dani Düsentrieb
 
Posts: 8
Joined: 15. April 2009 07:52

Re: Interner Serverfehler wenn mod_rewrite

Postby Nobbie » 14. June 2011 14:43

Dani Düsentrieb wrote:Bin für alle Hinweise Dankbar!


Dann schau in den error_log, da dürften jede Menge Hinweise drin stehen.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Interner Serverfehler wenn mod_rewrite

Postby Dani Düsentrieb » 23. June 2011 14:57

So ich hab den Fehler gefunden. Im error.log stand .htaccess: RewriteEngine not allowed here. Ich hab nach dem Fehler mal gegoogeld und da hat jemand geschrieben das ein AllowOverride All auf das root verzeichnis fehlt. In der httpd.conf war der drin aber in der extra/httpd-xampp.conf hat es beim root Verzeichnis gefehlt da stand AllowOverride AuthConfig. Nun klappts auch mit dem mod_rewrite.
Dani Düsentrieb
 
Posts: 8
Joined: 15. April 2009 07:52


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests