Apache Alias

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache Alias

Postby mAy^daY » 07. March 2004 12:51

hi, ich habe ein kleines problem...
folgendes habe ich in die httpd.conf eingetragen:
Code: Select all
Alias /lui "/home/lui/www"

<Directory /home/lui/www>
Order allow,deny
Allow from all
</Directory>


so, wenn ich jetzt die url aufrufe .../lui
kommt immer Forbidden:
You don't have permission to access /lui on this server.

die rechte für /www sind auf 775
und die index.html die darin ist auf 644

wo liegt nun der fehler hierbei?
(suche hat nichts ergeben, genauso wie http://httpd.apache.org/docs-2.0/en/mod/mod_alias.html)

mAy
mAy^daY
 
Posts: 16
Joined: 07. March 2004 12:43

Postby DJ DHG » 07. March 2004 14:08

Moin Moin

versuch es mal so.

Code: Select all
Alias /lui "/home/lui/www/"

    <Directory "/home/lui/www/">
        Options Indexes
        #DirectoryIndex index.php
        Order allow,deny
        Allow from all
    </Directory>


mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby mAy^daY » 07. March 2004 14:19

hmm klappt leider auch nicht...
immernoch "You don't have permission to access /lui on this server"

mAy
mAy^daY
 
Posts: 16
Joined: 07. March 2004 12:43

Postby mAy^daY » 07. March 2004 14:32

ich habe es jetzt anders versucht, jedoch immernoch "You don't have permission to access /lui on this server"

habe folgendes gemacht:
Code: Select all
UserDir disabled
UserDir enabled lui
UserDir /home/*/www

<Directory /home/*/www>
    AllowOverride FileInfo AuthConfig Limit
    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    <Limit GET POST OPTIONS PROPFIND>
        Order allow,deny
        Allow from all
    </Limit>
    <LimitExcept GET POST OPTIONS PROPFIND>
        Order deny,allow
        Deny from all
    </LimitExcept>
</Directory>

<Directory /home/*/www/cgi-bin/>
Options ExecCGI
SetHandler cgi-script
</Directory>


somit müsste man mit /~lui eigentlich in das /home/lui/www kommen...
ergebnis: gleiches prob wie vorher, 403 Forbidden

irgendwo muß ich doch was falsch gemacht haben...
oder zumindest nicht die erforderliche berechtigung gesetzt haben?!

gruß mAy
mAy^daY
 
Posts: 16
Joined: 07. March 2004 12:43

Postby koochie » 07. March 2004 21:25

Moin,
gibts du die index.html mit in der Url an? Oder hörst Du bei ".../lui" auf?
Ich habe den verdacht, dass dein DirectoryIndex nicht zieht?

gruss, Karsten
gruss, Karsten
User avatar
koochie
 
Posts: 14
Joined: 06. March 2004 16:15
Location: München

Postby mAy^daY » 07. March 2004 23:42

habe beides versucht...
mit und ohne

/lui, /lui/index.htm
oder /~lui, /~lui/index.htm

nichts funktioniert...


mAy
mAy^daY
 
Posts: 16
Joined: 07. March 2004 12:43


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests