You don't have permission to access...

Alles, was den Apache betrifft, kann hier besprochen werden.

You don't have permission to access...

Postby tigorean » 06. June 2011 16:22

Hallo,

habe ein alt bekanntes Problem, dessen Lösung mir nicht mehr einfällt...

Also, ich habe einen vps (debian) auf dem apache2 läuft, nun möchte ich den Ordnerinhalt anzeigen lassen, aber ich finde bei bestem willen nicht mehr, was ich in der config (und vorallem welcher) ändern muss.

You don't have permission to access /intern/ on this server.

apache2 hat rechte, also z.B. kann ich auf /intern/bilder.rar zugreifen aber der Ordnerinhalt wird nicht angezeigt.
Eine .htaccess habe ich auch erstellt und diese funktioniert scheinbar auch
Code: Select all
AuthUserFile /var/www/vhosts/default/htdocs/intern/.htpasswd
AuthName "XX"
AuthType Basic
<Limit GET>
require valid-user
</Limit>


Jetzt möchte ich gerne wissen, wo ich genau einstellen kann das die Ordnerinhalte (also /var/www/vhosts/default/htdocs/intern/) gezeigt werden, ich habe schon ewig gegooglet aber finde die Lösung nicht mehr :/

Ach ja hier noch ein Auszug aus dem error.log
Code: Select all
[Sun Jun 05 11:57:30 2011] [error] [client xx.xx.xx.xx] Directory index forbidden by Options directive: /var/www/vhosts/default/htdocs/intern/
tigorean
 
Posts: 1
Joined: 06. June 2011 16:14

Re: You don't have permission to access...

Postby terrorsnurf » 27. June 2011 12:43

Besteht das Problem noch?

Schau mal in deiner Virtual Host Konfiguration im <Directory> Block, dort gibt es Options Indexes, wenn bei dir steht
Code: Select all
Options -Indexes
ändere es auf
Code: Select all
Options +Indexes
.
Damit wird das Anzeigen des Ordner Inhalts erlaubt oder verboten.
terrorsnurf
 
Posts: 2
Joined: 27. June 2011 11:41


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests