vhost zeigt keine index.html an

Alles, was den Apache betrifft, kann hier besprochen werden.

vhost zeigt keine index.html an

Postby sykerjoe » 13. April 2011 09:28

Morgen habe ein Problem mit einem konfigurierten Vhost....

Er zeigt bei der Eingabe der Hostnamens keine index..html an sondern nur das obligatorische "it works", also greift auf die Defaultpage zu ... sobald ich die ip verwende klappt es mit der Darstellung.

Habe aber in meinem Client in der Host Datei einen DNS eintrag hinterlegt.

Meine Config sieht folgendermaßen aus:

Code: Select all
<VirtualHost 192.168.112.22>
        ServerName  linksite.local
       # ServerAlias linki.local
        ServerAdmin webmaster@localhost
        DocumentRoot /home/skyerjoe/html/
        <Directory /home/skyerjoe/html/>
                Options Indexes FollowSymLinks  +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>
        ErrorLog /var/log/apache2/error.log
        LogLevel warn
        CustomLog /var/log/apache2/access.log combined
        ServerSignature On
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

#               <Directory "/home/skyerjoe/html/">
#                AllowOverride None
#                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
#                Order allow,deny
##                Allow from all
#        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>




#Include /etc/apache2/sites-available/default-ssl.conf
        SSLEngine On
       SSLCertificateFile /etc/apache2/ssl/apache.pem
</VirtualHost>




Was issen da da an der config falsch ?


grüße sykerjoe
sykerjoe
 
Posts: 29
Joined: 21. December 2010 11:39

Re: vhost zeigt keine index.html an

Postby WilliL » 13. April 2011 20:46

wenn das die komplette vhosts ist, würde ich sie der "Sauberkeit" halber als erstes den localhost setzen.

sieh dir mal den DirectoryIndex im container <Directory xx> an, hier sollte er definiert werden - alternativ in einer .htaccess

Code: Select all
# localhost
<VirtualHost 127.0.0.1:80>
    ServerAdmin postmaster@localhost
    DocumentRoot "C:/xampp175b/htdocs"
    ServerName localhost
    ##ServerAlias www.dummy-host.localhost
    ErrorLog "logs/error-localhost.log"
    LogLevel warn
    CustomLog "logs/localhost-access.log" combined
    <Directory "C:/xampp175b/htdocs">
        Options Indexes FollowSymLinks Includes ExecCGI
        Order allow,deny
        Allow from all
        AllowOverride All
        DirectoryIndex index.php index.shtml index.html index.htm
    </Directory>
</VirtualHost>


empfehlendswert: http://httpd.apache.org/docs/2.2/de/vhosts/
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests