Apache service not started on Windows 7 Ultimate

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache service not started on Windows 7 Ultimate

Postby sandeept » 16. February 2011 07:43


I have Apache 2.2.16 running on port 8080 on Windows 7 Ultimate. It was working quite fine but for last one week, Apache service is not started when OS loads. Log file shows,

[Sat Feb 05 12:44:56 2011] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
Starting the Apache2.2 service(OS 5)Access is denied. : Apache2.2: Failed to open the service

I have searched forums for solutions and got few suggestions. These are,

1. Disable antivirus
2. Add following lines in httpd.conf

EnableMMAP off
EnableSendfile off

3. Reinstall Apache

None of above have helped.

If I double click httpd.exe in bin directory, I am able to run php scripts through browser. This trick works from command prompt too. But, Apache service in windows services panel shows "stopped". On clicking start, it says, requested service failed. Same message is shown when I try to start Apache from Apache monitor services.

Please help. Thanks in advance.

Posts: 1
Joined: 16. February 2011 07:40

Re: Apache service not started on Windows 7 Ultimate

Postby splion » 21. March 2011 15:54


do you reinstall the service manually?

httpd -k uninstall ...
httpd -k install ...

ciao Andreas
Posts: 44
Joined: 19. August 2004 15:32

Return to Apache

Who is online

Users browsing this forum: No registered users and 7 guests