Links werden falsch geroutet

Alles, was den Apache betrifft, kann hier besprochen werden.

Links werden falsch geroutet

Postby keyboard-billy » 17. November 2010 00:26

Hallo,

ich habe Apache schon ein paar mal installiert und hatte nie Probleme. Aber irgendwie lief mein System inzwischen gar nicht mehr. Deshalb habe ich mich heute entschlossen den Apache Webserver neu aufzusetzen. Ich verwende XP SP3 und Apache Version 2.2.17 (W32).

Ich habe im Verzeichnis "C:\Dokumente und Einstellungen\Administrator\public_html" meine Dateie "index.hml" abgelegt. Der Aufruf über "localhost/~Administrator" funktioniert soweit - der Inhalt der Datei "index.hml" wird korrekt angezeigt.
ABER: In der Datei "index.hml" befindet sich ein Link auf eine 2. Testseite:

Code: Select all
<html>
   <head>
      <title>Testseite</title>
   </head>
   <body>
      <h1>Die ist eine Testseite</h1>
      <a href="/page2.html" title="Testseite2">Testseite 2</a>
   </body>
</html>


Sobald ich mit der Maus auf den Link klicke, wird in der Fußzeile meine Browsers (FF 3.6.12) auf "/localhost" anstatt auf "/localhost/~Administrator" verwiesen.
In meinen früheren Apache-Installationen haben meine beiden Testdateien immer korrekt funktioniert. Was ist da falsch gelaufen?

Ich habe die Datei httpd-userdir.conf folgendermaßen konfiguriert:
Code: Select all
# Settings for user home directories
#
# Required module: mod_userdir

#
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.  Note that you must also set
# the default access control for these directories, as in the example below.
#
UserDir "public_html"

#
# Control access to UserDir directories.  The following is an example
# for a site where these directories are restricted to read-only.
#
<Directory "C:/Dokumente und Einstellungen/*/public_html">
    AllowOverride FileInfo AuthConfig Limit Indexes
    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    <Limit GET POST OPTIONS>
        Order allow,deny
        Allow from all
    </Limit>
    <LimitExcept GET POST OPTIONS>
        Order deny,allow
        Deny from all
    </LimitExcept>
</Directory>


Ich weiß einfach nicht weiter, woran das liegt. Muss ich noch irgendwelche Module laden oder etwas in der httpd.conf einstellen?
Bitte dringend um Hilfe!

Danke vielmals.
keyboard-billy
 
Posts: 4
Joined: 17. November 2010 00:04
Location: Nürnberg

Re: Links werden falsch geroutet

Postby keyboard-billy » 18. November 2010 19:13

Hallo,

ich habe mich mittlerweile durch die Doku und die config-Dateien geqält und habe eine Vermutung:

Meine ganze virtuellen Host laufen einwandfrei. Ich kann darin pro vhost ein DocumentRoot definieren.
Sämliche hart verdrahteten Links "/" in meinen HTML-Files verweisen somit in das DocumentRoot.

Ich habe über die Datei ..../conf/extra/httpd-userdir.conf mein UserDir definiert (Apache 2.2.17/M$ XP Pro SP3):

Code: Select all
# Settings for user home directories
#
# Required module: mod_userdir

#
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.  Note that you must also set
# the default access control for these directories, as in the example below.
#
UserDir "Users/*/Eigene Dateien/public_html"
#
# Control access to UserDir directories.  The following is an example
# for a site where these directories are restricted to read-only.
#
<Directory "C:/Dokumente und Einstellungen/*/Eigene Dateien/public_html">
    AllowOverride FileInfo AuthConfig Limit Indexes
    Options Indexes FollowSymLinks
    Order deny,allow
    Allow from all
#    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
</Directory>


Was kann man machen, damit die hart verdahteten Links in den HTML-Dateien nicht auf http://localhost/ sondern auf http://localhost/~[username]/ aufgelöst werden?

Danke für Euere freundliche Unterstützung in voraus.

(... ja ich habe das Modul mod_userdir geladen und ja, ich habe in der httpd.conf die Zeile "Include conf/extra/httpd-userdir.conf" auskommentiert :wink: )

Gruß,
Billy
keyboard-billy
 
Posts: 4
Joined: 17. November 2010 00:04
Location: Nürnberg

Re: Links werden falsch geroutet

Postby Nobbie » 18. November 2010 23:34

keyboard-billy wrote:Was kann man machen, damit die hart verdahteten Links in den HTML-Dateien nicht auf http://localhost/ sondern auf http://localhost/~[username]/ aufgelöst werden?


Gar nichts. Das geht nicht.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: Links werden falsch geroutet

Postby keyboard-billy » 19. November 2010 14:52

@Nobbie
Gar nichts. Das geht nicht.


... bedeutet mit anderen Worten, dass Seiten, die im public_html liegen, nicht hart verdrahtet werden dürfen? :shock:
Ich bin mir nicht ganz sicher, galuber aber, dass dasfrüher mal ging :?:
keyboard-billy
 
Posts: 4
Joined: 17. November 2010 00:04
Location: Nürnberg

Re: Links werden falsch geroutet

Postby Nobbie » 21. November 2010 13:24

keyboard-billy wrote:... bedeutet mit anderen Worten, dass Seiten, die im public_html liegen, nicht hart verdrahtet werden dürfen? :shock:


Richtig und falsch. Sie sind ja nicht "hart" verdrahtet, sondern nur "halbhart". Es fehlt ja sowohl das Protokoll (http) wie auch die Domain, als auch der UserPfad. Du könntest ja auch so verlinken:

Code: Select all
href="/~Administrator/index.html"


Diese Syntax funktioniert natürlich richtig.

oder komplett

Code: Select all
href="http://www.domain.de/~Administrator/index.html"


Oder eben gar nichts angeben, sondern den Dokumentnamen:

Code: Select all
href="index.html"


Aber dieses Zwischending, halb hart halb weich, das funktioniert nicht.


keyboard-billy wrote:Ich bin mir nicht ganz sicher, galuber aber, dass dasfrüher mal ging :?:


Ne, ganz sicher nicht. Hart verdrahtet ist hart verdrahtet - und das bezieht sich immer auf den DocumentRoot (oder einen Alias).

Natürlich könntest Du den DocumentRoot so festlegen, dass der auf /home/Administrator/public_html verweist - aber dann liegt ALLES dort und es funktioniert dann auch nur für den User Administrator.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

GELÖST - Links werden falsch geroutet

Postby keyboard-billy » 25. November 2010 21:30

@all

Vielen Dank.
keyboard-billy
 
Posts: 4
Joined: 17. November 2010 00:04
Location: Nürnberg


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests