Probleme bei der Konfiguration des Apache2

Alles, was den Apache betrifft, kann hier besprochen werden.

Probleme bei der Konfiguration des Apache2

Postby Ishildur » 10. November 2010 23:59

Hallo zusammen
Ich habe folgendes Problem bei der Konfiguration des Apache Webservers. Ganz grob versuche ich folgendes zu machen:

Die Situation ist folgende. Ich habe mehrere fremde Websiten auf meinem Server gehostet sowie auch meine eigene. Zusätzlich habe ich bestimmte Projekte, an denen ich jeweils gerade arbeite mit DAV in Apache eingebunden. Nun möchte ich natürlich nicht, dass folgendes möglich ist. svn.einefremdedomaindibeimirgehostetist.ch/myproject und auch www.meinedomain.ch/myproject sollte nicht auf das repository führen. Nur svn.meinedomain.ch/myproject soll funktionieren.

Folgendes habe ich also mal versucht:
Code: Select all
<VirtualHost _default_:443>
 <Directory />
   Order deny,allow
   deny from all
  </Directory>

 # Wichtige sachen
</VirtualHost>

<VirtualHost svn.mydomain.ch:443>
 # Wichtige sachen

 <Location /myrep>
  DAV svn
  # wichtige Sachen
 </Location>
</VirtualHost>


Aber irgendwie habe ich den Eindruck, dass er immer auf <VirtualHost _default_:443> auch dann, wenn ich https://svn.mydomain.ch im Browser eintippe...

Könnt Ihr mir helfen und mir aufzeigen, was ich falsch mache?
Herzlichen Dank
Ishildur
 
Posts: 4
Joined: 10. November 2010 23:34

Re: Probleme bei der Konfiguration des Apache2

Postby Nobbie » 11. November 2010 09:25

Zum 100-Millionsten Mal die 100-Millionste Antwort auf die 100-Millionste gleiche Frage:

Es fehlt die NameVirtualHost Anweisung.

Und damit gleich die 100-Millionste Gegenfrage: wieso liest auch Du die Doku nicht? Da steht das drin, ganz sicher.
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04

Re: Probleme bei der Konfiguration des Apache2

Postby Ishildur » 11. November 2010 14:29

@Nobbie
Zwar nicht zum millionsten mal aber dennoch gerne hier den Inhalt der Datei /etc/apache2/ports.conf
Code: Select all
NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
 NameVirtualHost *:443
 Listen 443
</IfModule>


Zu deiner millionsten Gegenfrage bezüglich dem Lesen des Manuals: Vielleicht weil man nicht Wochen damit verbringen möchte, das Manual zu studieren für eine Einstellung die eigentlich Minuten in Anspruch nehmen sollte und dies ohne überhaupt zu wissen, ob die gewünschte Anforderung überhaupt realisierbar ist...

Mfg Samuel

P.S.
Spricht nicht gerade für den Apache2 wenn millionen von Benutzer in die gleichen Fettnäpfchen zu treten scheinen...
Ishildur
 
Posts: 4
Joined: 10. November 2010 23:34

Re: Probleme bei der Konfiguration des Apache2

Postby Ishildur » 11. November 2010 14:53

Das Logfile zeigt sehr schön, dass er auf die falsche Resource zugreifen will:

File does not exist:
[Thu Nov 11 14:48:52 2010] [error] [client xxx.xxx.xxx.xxx] File does not exist: /var/www/mydomain

Im Konfig steht aber:

Code: Select all
<VirtualHost mydomain:443>
 <Location /serenity>
  # svn settings
  DAV           svn
  SVNPath       /dta/sv/mydomain


Im /etc/apache2/sites-available/defaul-ssl steht:

Code: Select all
<VirtualHost _default_:443>
        DocumentRoot /var/www/


Also greift er auf den falschen VirtualHost, aber warum nur?
Ishildur
 
Posts: 4
Joined: 10. November 2010 23:34

Re: Probleme bei der Konfiguration des Apache2

Postby Ishildur » 11. November 2010 15:08

Was ich feststelle ist nocht, dass es nur mit HTTPS nicht funktioniert. Mit HTTP funktionierts...
Ishildur
 
Posts: 4
Joined: 10. November 2010 23:34

Re: Probleme bei der Konfiguration des Apache2

Postby Nobbie » 11. November 2010 16:02

Ishildur wrote:Zu deiner millionsten Gegenfrage bezüglich dem Lesen des Manuals: Vielleicht weil man nicht Wochen damit verbringen möchte, das Manual zu studieren für eine Einstellung die eigentlich Minuten in Anspruch nehmen sollte und dies ohne überhaupt zu wissen, ob die gewünschte Anforderung überhaupt realisierbar ist...


Ach so, also fragt man Leute, die nicht so faul sind, denn irgendeiner MUSS die Doku dafür lesen (ich beispielsweise).

Ishildur wrote:Spricht nicht gerade für den Apache2 wenn millionen von Benutzer in die gleichen Fettnäpfchen zu treten scheinen...


Schöner Versuch, die eigene Unfähigkeit Apache in die Schuhe zu schieben.

Aber wie es aussieht, machst Du anscheinend einen anderen Fehler. Die Stelle ist wirkungsvoll abgeschirmt durch die Auskommentierung "#wichtige Sachen". In diesen wichtigen Sachen solltest Du auf Fehlersuche gehen. Oder irgendwo anders, da wir ja ohnehin nur Fragmente für die Definition der VirtualHosts gezeigt bekommen.

Mit Hilfe der Doku wirst es sicherlich finden :-)
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests