Virtual Hosting Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

Virtual Hosting Problem

Postby rsw2003 » 03. November 2010 05:08

I'm using xampp. I have windows xp. Apache was working fine until I changed the file C:/xampp/apache/conf/extra/httpd-vhosts.conf

This is what I added:

<Directory C:/vhosts>
Order Deny, Allow
Allow from all
</Directory>

<VirtualHost *:80>
DocumentRoot c:/xampp/htdocs
ServerName localhost
</VirtualHost>

<VirtualHost *:80>
DocumentRoot c:/vhosts/phpcs5
ServerName phpcs5
</VirtualHost>



I made sure all other hashes were present except for this one in the same file:

NameVirtualHost *:80



Before doing this, Apache was fine...now it does not work. It starts to run but quickly shuts down. I did create a vhosts folder under C:, and phpcs5 folder under vhosts folder. Localhost was working since Apache was. If Apache is not running surely http://localhost does not either.

I'm really stumped here and about to use virtual hosts in the other way if I can't figure this out.
rsw2003
 
Posts: 2
Joined: 03. November 2010 04:54

Re: Virtual Hosting Problem

Postby rsw2003 » 03. November 2010 05:17

I forgot to mention I also went into C:\Windows\System32\drivers\etc\hosts

I typed 127.0.0.1 localhost at the bottom again (already at top of file)
and then typed:
127.0.0.1 phpcs5 for the first time underneath and then saved

I have since went back in and deleted all changes and Apache is running again.
rsw2003
 
Posts: 2
Joined: 03. November 2010 04:54

Re: Virtual Hosting Problem

Postby Nobbie » 03. November 2010 23:51

Dann schau doch mal im error_log von Apache nach, da steht ganz sicher eine Meldung, warum Apache nicht starten kann.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests